brcm63xx: Add DT support for DV-201AMR
authorJonas Gorski <jogo@openwrt.org>
Mon, 24 Nov 2014 14:44:28 +0000 (14:44 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 24 Nov 2014 14:44:28 +0000 (14:44 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 43361

target/linux/brcm63xx/dts/dv-201amr.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
target/linux/brcm63xx/patches-3.14/514-board_ct536_ct5621.patch
target/linux/brcm63xx/profiles/davolink.mk [new file with mode: 0644]

diff --git a/target/linux/brcm63xx/dts/dv-201amr.dts b/target/linux/brcm63xx/dts/dv-201amr.dts
new file mode 100644 (file)
index 0000000..9f8660a
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+       model = "Davolink DV-201AMR";
+       compatible = "davolink,dv-201amr", "brcm,bcm6348";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       backup@0 {
+               label = "backup";
+               reg = <0x000000 0x400000>;
+       };
+
+       cfe@400000 {
+               label = "cfe";
+               reg = <0x400000 0x010000>;
+               read-only;
+       };
+
+       linux@410000 {
+               label = "linux";
+               reg = <0x410000 0x3f0000>;
+       };
+};
index 89eefa3ca77c36a5ba6c897e83412285a2253b7a..fc290c660610bc413362cb1304714f50eef3df79 100755 (executable)
@@ -57,6 +57,13 @@ define Image/Build/CFEDTB
                $(7) $(8) $(9) $(10)
 endef
 
+define Image/Build/OLDCFEDTB
+       $(TOPDIR)/scripts/brcmImage.pl -t -p \
+               -b $(3) -c $(4) -e $(KERNEL_ENTRY) -a $(LOADADDR) \
+               -k $(KDIR)/vmlinux-$(2).lzma.cfe -r $(KDIR)/root.$(1) \
+               -o $(BIN_DIR)/openwrt-$(5)-$(1)-cfe.bin $(6)
+endef
+
 define Image/Build/ZYXCFEDTB
        # Generate the tagged image
        $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux-$(2).lzma.cfe -f $(KDIR)/root.$(1) \
@@ -94,14 +101,6 @@ define Image/Build/SPW303V
        rm -f $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin.tmp
 endef
 
-define Image/Build/CFEOLD
-       $(TOPDIR)/scripts/brcmImage.pl -t -p    \
-               -b $(2) -c $(3)                 \
-               -k $(KDIR)/vmlinux.lzma.cfe     \
-               -r $(KDIR)/root.$(1)            \
-               -o $(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin
-endef
-
 define Image/Build/HCS
        $(STAGING_DIR_HOST)/bin/hcsmakeimage --magic_byte=$(3) \
                --rev_maj=$(4) --rev_min=$(5) --input_file=$(6) \
@@ -193,6 +192,23 @@ define CfeImageDTB
   TARGET_$(1)_IMAGES += $(5)
 endef
 
+# $(1) = Profile
+# $(2) = dtb
+# $(3) = boardname
+# $(4) = chipid
+# $(5) = imagename
+# $(6) = additional options
+define OldCfeImageDTB
+  define Image/Build/$(5)
+        $$(call Image/Build/OLDCFEDTB,$$(1),$(2),$(3),$(4),$(5),$(6))
+  endef
+
+  TARGET_Default_DTBS += $(2)
+  TARGET_Default_IMAGES += $(5)
+  TARGET_$(1)_DTBS += $(2)
+  TARGET_$(1)_IMAGES += $(5)
+endef
+
 # $(1) = Profile
 # $(2) = dtb
 # $(3) = boardname
@@ -237,8 +253,6 @@ define Image/Build
        # Sagem F@ST2504n
        $(call Image/Build/CFE,$(1),F@ST2504n,6362,F@ST2504n,OpenWRT-$(REVISION))
 
-       # Davolink DV201AMR
-       $(call Image/Build/CFEOLD,$(1),DV201AMR,6348)
        # USR 9108
        $(call Image/Build/CFE,$(1),96348GW-A,6348,USR9108)
        # NetGear DG834GT, DG834PN
@@ -350,6 +364,8 @@ $(eval $(call CfeImageDTB,DSL274XB_C,dsl-274xb-c,96358GW,6358,DSL274XB-C2))
 $(eval $(call CfeImageDTB,DSL274XB_C,dsl-274xb-c,AW4139,6358,DSL274XB-C3))
 # D-Link DVA-G3810BN/TL
 $(eval $(call CfeImageDTB,DVAG3810BN,dva-g3810bn_tl,96358VW,6358,DVAG3810BN))
+# Davolink DV-201AMR
+$(eval $(call OldCfeImageDTB,DV201AMR,dv-201amr,DV201AMR,6348,DV-201AMR))
 # Huawei HG520v
 $(eval $(call CfeImageDTB,HG520v,hg520v,HW6358GW_B,6358,HG520v,EchoLife_HG520v))
 # Huawei HG553
index 765cf2a79f66e6dca8ae56231fe269d2909922fc..a602017d38b26a702a77607ef02815a6bbe6e774 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -736,6 +736,43 @@ static const struct board_info __initcon
+@@ -736,6 +736,44 @@ static const struct board_info __initcon
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
@@ -37,6 +37,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 +      { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
 +      { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
 +      { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
++      { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
 +      { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
 +      { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
 +#endif
index 4b5cc13c2ff99ec24cc2cf2a325afa1d514a46bb..4c44094d435b54c6fa74b1ce837bf9fbf16c149f 100644 (file)
@@ -73,6 +73,6 @@
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
 +      { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
 +      { .compatible = "comtrend,ct-5621", .data = &board_ct536_ct5621, },
+       { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
        { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
        { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
-       { .compatible = "t-com,spw500v", .data = &board_spw500v, },
diff --git a/target/linux/brcm63xx/profiles/davolink.mk b/target/linux/brcm63xx/profiles/davolink.mk
new file mode 100644 (file)
index 0000000..0097a80
--- /dev/null
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DV201AMR
+  NAME:=Davolink DV-201AMR
+  PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/DV201AMR/Description
+  Package set optimized for DV-201AMR.
+endef
+$(eval $(call Profile,DV201AMR))