projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
|
inline
| side by side (parent:
6f473c9
)
[packages] gzip: update to v1.3.12, add gunzip & zcat scripts, cleanup
author
Nicolas Thill
<nico@openwrt.org>
Mon, 5 Oct 2009 13:48:45 +0000
(13:48 +0000)
committer
Nicolas Thill
<nico@openwrt.org>
Mon, 5 Oct 2009 13:48:45 +0000
(13:48 +0000)
SVN-Revision: 17880
utils/gzip/Makefile
patch
|
blob
|
history
diff --git
a/utils/gzip/Makefile
b/utils/gzip/Makefile
index 50baf8a8b092113a20467abbeee4324f7de6c7c8..17518d46eed169ddf5a7b223bcbfa48528f0f1d6 100644
(file)
--- a/
utils/gzip/Makefile
+++ b/
utils/gzip/Makefile
@@
-1,5
+1,5
@@
#
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006
-2009
OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@
-8,12
+8,12
@@
include $(TOPDIR)/rules.mk
PKG_NAME:=gzip
include $(TOPDIR)/rules.mk
PKG_NAME:=gzip
-PKG_VERSION:=1.3.
3
+PKG_VERSION:=1.3.
12
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=
http://www.gzip.org
/
-PKG_MD5SUM:=
52eaf713673507d21f7abefee98ba662
+PKG_SOURCE_URL:=
@GNU/gzip
/
+PKG_MD5SUM:=
b5bac2d21840ae077e0217bc5e4845b1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/package.mk
@@
-30,22
+30,16
@@
define Package/gzip/description
replacement for compress.
endef
replacement for compress.
endef
-define Build/Configure
- $(call Build/Configure/Default, \
- --prefix=/usr \
- );
-endef
-
define Build/Compile
define Build/Compile
- $(
call Build/Compile/Default,
\
-
CFLAGS="$(TARGET_CFLAGS
)" \
- LDFLAGS="$(TARGET_LDLAGS)" \
- )
+ $(
MAKE) -C $(PKG_BUILD_DIR)
\
+
DESTDIR="$(PKG_INSTALL_DIR
)" \
+ all install
+ $(SED) 's,/bin/bash,/bin/sh,g' $(PKG_INSTALL_DIR)/usr/bin/{gunzip,zcat}
endef
define Package/gzip/install
endef
define Package/gzip/install
- mkdir -p $(1)/usr/bin/
- $(
INSTALL_BIN) $(PKG_BUILD_DIR)/gzip
$(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(
CP) $(PKG_INSTALL_DIR)/usr/bin/{gunzip,gzip,zcat}
$(1)/usr/bin/
endef
$(eval $(call BuildPackage,gzip))
endef
$(eval $(call BuildPackage,gzip))