[package] broadcom-wl: update to v5.10.56.27.1, initial brcm63xx (MIPS BE) support
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 1 Jul 2010 01:31:28 +0000 (01:31 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 1 Jul 2010 01:31:28 +0000 (01:31 +0000)
SVN-Revision: 22008

package/broadcom-wl/Makefile
package/broadcom-wl/patches/001-kernel-2.6.34_compat.patch [deleted file]

index ebf9b38618735503f130d7e1ca1850a128d3fa4a..d8e07eb5a7d3c0ad461491fcb15583c587ade596 100644 (file)
@@ -9,12 +9,15 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=broadcom-wl
-PKG_VERSION:=5.10.56.27.0
+PKG_VERSION:=5.10.56.27.1
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)_$(ARCH).tar.bz2
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=dfaee8bdafaa4bb5ccbcdfe541c29e7d
+
+PKG_MD5SUM.mipsel:=9f42cfa9c46ee1b0e04dc2d3ab9bc8cd
+PKG_MD5SUM.mips:=9dcc902af0fcac5f34b6656982e82c21
+PKG_MD5SUM:=$(PKG_MD5SUM.$(ARCH))
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,13 +26,13 @@ define Package/broadcom-wl/Default
   CATEGORY:=Kernel modules
   DEPENDS:=@PACKAGE_kmod-brcm-wl||PACKAGE_kmod-brcm-wl-mini
   SUBMENU:=Proprietary BCM43xx WiFi driver
-  SUBMENUDEP:=@TARGET_brcm47xx
+  SUBMENUDEP:=@TARGET_brcm47xx||TARGET_brcm63xx
 endef
 
 define KernelPackage/brcm-wl/Default
   $(call Package/broadcom-wl/Default)
   SECTION:=kernel
-  DEPENDS:=@TARGET_brcm47xx +wireless-tools
+  DEPENDS:=@TARGET_brcm47xx||TARGET_brcm63xx +wireless-tools
   TITLE:=Kernel driver for BCM43xx chipsets
   FILES:=$(PKG_BUILD_DIR)/driver$(1)/wl.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,30,wl)
diff --git a/package/broadcom-wl/patches/001-kernel-2.6.34_compat.patch b/package/broadcom-wl/patches/001-kernel-2.6.34_compat.patch
deleted file mode 100644 (file)
index 1ca3626..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/driver/include/linuxver.h
-+++ b/driver/include/linuxver.h
-@@ -19,8 +19,10 @@
- #include <linux/version.h>
- #if (LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0))
- #include <linux/config.h>
--#else
-+#elif (LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 34))
- #include <linux/autoconf.h>
-+#else
-+#include <generated/autoconf.h>
- #endif
- #include <linux/module.h>
-@@ -111,7 +113,6 @@ typedef irqreturn_t(*FN_ISR) (int irq, v
- #if defined(CONFIG_PCMCIA) || defined(CONFIG_PCMCIA_MODULE)
--#include <pcmcia/version.h>
- #include <pcmcia/cs_types.h>
- #include <pcmcia/cs.h>
- #include <pcmcia/cistpl.h>