[package] update cyassl to 1.0.2 (#5049)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 7 May 2009 21:04:46 +0000 (21:04 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 7 May 2009 21:04:46 +0000 (21:04 +0000)
SVN-Revision: 15703

libs/cyassl/Makefile
libs/cyassl/patches/001-fix_buffer_overflow.patch [deleted file]

index 83edf408d4f8c430eecb7047f8b1f100bea6fdd8..0d2e178a3d30c955551e1be74ffbb21384c7310e 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cyassl
-PKG_VERSION:=0.9.9
+PKG_VERSION:=1.0.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
 PKG_SOURCE_URL:=http://www.yassl.com/
-PKG_MD5SUM:=2fe084425e7c049d4f03ceed6b61af52
+PKG_MD5SUM:=23b8d695846cb5fb7eeddc5991d3c179
 PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
diff --git a/libs/cyassl/patches/001-fix_buffer_overflow.patch b/libs/cyassl/patches/001-fix_buffer_overflow.patch
deleted file mode 100644 (file)
index bfbb72d..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -pruN cyassl-0.9.9.orig/ctaocrypt/include/hmac.h cyassl-0.9.9/ctaocrypt/include/hmac.h
---- cyassl-0.9.9.orig/ctaocrypt/include/hmac.h 2008-12-11 16:27:12.490140301 +0100
-+++ cyassl-0.9.9/ctaocrypt/include/hmac.h      2008-12-11 16:27:50.318874180 +0100
-@@ -61,7 +61,7 @@ typedef struct Hmac {
-     Hash    hash;
-     word32  ipad[HMAC_BLOCK_SIZE  / sizeof(word32)];  /* same block size all*/
-     word32  opad[HMAC_BLOCK_SIZE  / sizeof(word32)];
--    word32  innerHash[SHA_DIGEST_SIZE / sizeof(word32)]; /* max size */
-+    word32  innerHash[SHA256_DIGEST_SIZE / sizeof(word32)]; /* max size */
-     byte    macType;                                     /* md5 sha or sha256 */
-     byte    innerHashKeyed;                              /* keyed flag */
- } Hmac;