fix a few overfull hboxes, remove some redundant stuff
authorFelix Fietkau <nbd@openwrt.org>
Sat, 4 Aug 2007 11:58:31 +0000 (11:58 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 4 Aug 2007 11:58:31 +0000 (11:58 +0000)
SVN-Revision: 8341

docs/adding.tex
docs/build.tex
docs/config.tex

index b1712ac9d26ac558737632598acdbba2437dc190..2b47e6a328a96e0963b6ef96c8cd71d4adc1e173 100644 (file)
@@ -357,7 +357,7 @@ firmware image and flash is structured. You will find below a commented example
 that covers the case of the device where the bootloader can pass to the kernel its partition plan.
 
 First of all, you need to make your flash map driver be visible in the kernel 
-configuration options, this can be done by editing the file 
+configuration options, this can be done by editing the file \
 \textbf{linux/drivers/mtd/maps/Kconfig}:
 
 \begin{verbatim}
index 03bd1a967585078c29ba4e11435b34486cb433f7..c45b905040c09b7fc5290c479130e09adae02ebd 100644 (file)
@@ -202,12 +202,6 @@ simplifies the entire ordeal.
 Here for example, is \texttt{package/bridge/Makefile}:
 
 \begin{Verbatim}[frame=single,numbers=left]
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 # $Id: Makefile 5624 2006-11-23 00:29:07Z nbd $
 
 include $(TOPDIR)/rules.mk
@@ -229,12 +223,14 @@ define Package/bridge
   SECTION:=net
   CATEGORY:=Base system
   TITLE:=Ethernet bridging configuration utility
-  DESCRIPTION:=\
-    Manage ethernet bridging: a way to connect networks together to \\\
-    form a larger network.
   URL:=http://bridge.sourceforge.net/
 endef
 
+define Package/bridge/description
+  Manage ethernet bridging: 
+  a way to connect networks together to form a larger network.
+endef
+
 define Build/Configure
     $(call Build/Configure/Default, \
         --with-linux-headers="$(LINUX_DIR)" \
@@ -384,12 +380,6 @@ For external kernel modules, you can add them to the build system just like if t
 Here for instance the Makefile for the I2C subsytem kernel modules :
 
 \begin{Verbatim}[frame=single,numbers=left]
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 # $Id $
 
 I2CMENU:=I2C Bus
@@ -398,8 +388,7 @@ define KernelPackage/i2c-core
   TITLE:=I2C support
   DESCRIPTION:=Kernel modules for i2c support
   SUBMENU:=$(I2CMENU)
-  KCONFIG:=$(CONFIG_I2C_CORE) \
-        $(CONFIG_I2C_DEV)
+  KCONFIG:=CONFIG_I2C_CORE CONFIG_I2C_DEV
   FILES:=$(MODULES_DIR)/kernel/drivers/i2c/*.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,i2c-core i2c-dev)
 endef
index f3802198edabcb5fb0723d216d96648760ac2716..d13297c4f79d8b2929a899b62d5eea8725f5a2cd 100644 (file)
@@ -61,8 +61,11 @@ You can access already processed options with the \texttt{config\_get} command
 Syntax:
 
 \begin{Verbatim}
-config_get <section> <option>            # prints the value of the option
-config_get <variable> <section> <option> # stores the value inside the variable
+# print the value of the option
+config_get <section> <option>
+
+# store the value inside the variable
+config_get <variable> <section> <option>
 \end{Verbatim}
 
 In busybox ash the three-option \texttt{config\_get} is faster, because it does not