add menuconfig option for enabling debugfs support in the kernel
authorGabor Juhos <juhosg@openwrt.org>
Tue, 8 Sep 2009 07:25:20 +0000 (07:25 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 8 Sep 2009 07:25:20 +0000 (07:25 +0000)
SVN-Revision: 17540

Config.in
include/kernel-defaults.mk

index 699c689406216d281c23dd3602534f48939f7158..e03cf03af33ebd21bd7181890355be05bc46d566 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -195,6 +195,7 @@ config KERNEL_KALLSYMS
        default n
        help
                This will give you more information in stack traces from kernel oopses
+
 config KERNEL_PROFILING
        bool "Compile the kernel with profiling enabled"
        default n
@@ -202,6 +203,15 @@ config KERNEL_PROFILING
                Enable the extended profiling support mechanisms used by profilers such
                as OProfile.
 
+config KERNEL_DEBUG_FS
+       bool "Compile the kernel with Debug Filesystem enabled"
+       depends LINUX_2_6
+       default y
+       help
+               debugfs is a virtual file system that kernel developers use to put
+               debugging files into. Enable this option to be able to read and
+               write to these files.
+
 endmenu
 
 menuconfig DEVEL
index 4266157d266e9998e64810ce8f4793dbd6f26600..cf3eb31053cf9f5e2ac39a6b61e0dada705e062a 100644 (file)
@@ -97,6 +97,7 @@ define Kernel/Configure/Default
        $(LINUX_CONFCMD) > $(LINUX_DIR)/.config.target
        echo "$(if $(CONFIG_KERNEL_KALLSYMS),CONFIG_KALLSYMS=y,# CONFIG_KALLSYMS is not set)" >> $(LINUX_DIR)/.config.target
        echo "$(if $(CONFIG_KERNEL_PROFILING),CONFIG_PROFILING=y,# CONFIG_PROFILING is not set)" >> $(LINUX_DIR)/.config.target
+       echo "$(if $(CONFIG_KERNEL_DEBUG_FS),CONFIG_DEBUG_FS=y,# CONFIG_DEBUG_FS is not set)" >> $(LINUX_DIR)/.config.target
        echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
        echo "# CONFIG_KALLSYMS_ALL is not set" >> $(LINUX_DIR)/.config.target
        echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target