adding terminal emulator rxvt
authorMirko Vogt <mirko@openwrt.org>
Wed, 11 Feb 2009 23:16:15 +0000 (23:16 +0000)
committerMirko Vogt <mirko@openwrt.org>
Wed, 11 Feb 2009 23:16:15 +0000 (23:16 +0000)
SVN-Revision: 14480

Xorg/app/rxvt/Makefile [new file with mode: 0644]
Xorg/app/rxvt/files/icon.png [new file with mode: 0644]
Xorg/app/rxvt/files/rxvt.desktop [new file with mode: 0644]

diff --git a/Xorg/app/rxvt/Makefile b/Xorg/app/rxvt/Makefile
new file mode 100644 (file)
index 0000000..8012851
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2007-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# blogic@openwrt.org
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=rxvt
+PKG_RELEASE:=1
+PKG_VERSION:=2.7.10
+PKG_SOURCE_URL:=@SF/rxvt
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL:=1
+
+#TARGET_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Package/rxvt
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  DEPENDS:=+libX11 +libXext +libXau +libXtst +imlib2
+  TITLE:=rxvt
+  URL:=http://rxvt.sourceforge.net
+endef
+
+define Package/rxvt/install
+       $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/share/applications $(1)/usr/share/icons
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/* \
+               $(1)/usr/bin/
+       $(INSTALL_DATA) \
+               ./files/rxvt.desktop \
+               $(1)/usr/share/applications/rxvt.desktop
+       $(INSTALL_DATA) \
+               ./files/icon.png \
+               $(1)/usr/share/icons/rxvt.png
+endef
+
+$(eval $(call BuildPackage,rxvt))
diff --git a/Xorg/app/rxvt/files/icon.png b/Xorg/app/rxvt/files/icon.png
new file mode 100644 (file)
index 0000000..9206d2f
Binary files /dev/null and b/Xorg/app/rxvt/files/icon.png differ
diff --git a/Xorg/app/rxvt/files/rxvt.desktop b/Xorg/app/rxvt/files/rxvt.desktop
new file mode 100644 (file)
index 0000000..8ea2eb3
--- /dev/null
@@ -0,0 +1,13 @@
+[Desktop Entry]
+GenericName=Terminal
+Name=rxvt
+Encoding=UTF-8
+Version=1.0
+Comment=Terminal Emulator
+StartupNotify=false
+Exec=rxvt
+Icon=/usr/share/icons/rxvt.png
+Terminal=false
+Type=Application
+SingleInstance=true
+Categories=Utility