[packages] miniupnpd: add the kernel headers shipped by iptables to CFLAGS
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 24 Jan 2010 23:01:01 +0000 (23:01 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 24 Jan 2010 23:01:01 +0000 (23:01 +0000)
SVN-Revision: 19320

net/miniupnpd/Makefile

index 6122342882d949548bbaa092213c66a156716050..5495689ef76179f54bc27cbbc0ed8f6461736507 100644 (file)
@@ -35,7 +35,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.openwrt \
                $(TARGET_CONFIGURE_OPTS) \
                STAGING_DIR="$(STAGING_DIR)" \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -DIPTABLES_143" \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(firstword $(wildcard $(KERNEL_BUILD_DIR)/iptables-*/include)) -DIPTABLES_143" \
                LIBS="$(STAGING_DIR)/usr/lib/libiptc.so $(STAGING_DIR)/usr/lib/libip4tc.so $(STAGING_DIR)/usr/lib/libip6tc.so"
 endef