[package] busybox: avoid infinite loop in lsmod (#4834)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 29 Mar 2009 20:26:45 +0000 (20:26 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 29 Mar 2009 20:26:45 +0000 (20:26 +0000)
SVN-Revision: 15071

package/busybox/Makefile
package/busybox/patches/810-lsmod-infinite-loop.patch [new file with mode: 0644]

index 3f27ec66c432d4fa18ef1f23875032d1b4dae92c..8eede359937cf66649403906b959b23e55618d7e 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.11.3
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
diff --git a/package/busybox/patches/810-lsmod-infinite-loop.patch b/package/busybox/patches/810-lsmod-infinite-loop.patch
new file mode 100644 (file)
index 0000000..8bc8cd0
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/modutils/lsmod.c
++++ b/modutils/lsmod.c
+@@ -107,7 +107,7 @@
+                               continue;
+                       } else if (errno != ENOSPC)
+                               bb_perror_msg_and_die("module %s: QM_REFS", mn);
+-                      deps = xrealloc(deps, count);
++                      deps = xrealloc(deps, depsize = count);
+               }
+               printf("%-20s%8lu%4ld", mn, info.size, info.usecount);
+               if (info.flags & NEW_MOD_DELETED)