[buildroot] allow download urls using the file:// schema (#6480)
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 13 Jan 2010 19:38:53 +0000 (19:38 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 13 Jan 2010 19:38:53 +0000 (19:38 +0000)
SVN-Revision: 19120

include/download.mk

index 78848b9c956d2004071c600bf51bcd8c8bbd1c30..a50a5e9362a4661b2e77b5b33bcaef7ffde03177 100644 (file)
@@ -11,7 +11,7 @@ DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
 define dl_method 
 $(strip \
   $(if $(2),$(2), \
-    $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% ftp://% http://%,$(1)),default, \
+    $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% ftp://% http://% file://%,$(1)),default, \
       $(if $(filter git://%,$(1)),git, \
         $(if $(filter svn://%,$(1)),svn, \
           $(if $(filter cvs://%,$(1)),cvs, \