move sysfs to mount_root
authorMike Baker <mbm@openwrt.org>
Wed, 1 Feb 2006 10:47:17 +0000 (10:47 +0000)
committerMike Baker <mbm@openwrt.org>
Wed, 1 Feb 2006 10:47:17 +0000 (10:47 +0000)
SVN-Revision: 3107

openwrt/package/base-files/Makefile
openwrt/package/base-files/default/etc/preinit
openwrt/package/base-files/default/sbin/mount_root

index 958262761e3133abb940f8d6f9dcac7c85f1b4a8..e4753d045cd03b704f6d19cef7bd27b1ed8b2d0a 100644 (file)
@@ -55,6 +55,7 @@ $(IPKG_BASE):
        cp -a ./default/* $(IDIR_BASE)
        $(SED) 's,$$R,r$(REV),g' $(IDIR_BASE)/etc/banner
        $(SED) 's,$$S,$(BOARD)-$(KERNEL),g' $(IDIR_BASE)/etc/ipkg.conf
+       mkdir -p $(IDIR_BASE)/sys
        mkdir -p $(IDIR_BASE)/jffs
        mkdir -p $(IDIR_BASE)/dev
        mkdir -p $(IDIR_BASE)/proc
index f82823ec9c5b8b45e9c76696f13adb05f1ea5f57..ac9039ca7175f5d7681b3704a118877827e57764 100755 (executable)
@@ -21,9 +21,4 @@ mount_root ${FAILSAFE:+failsafe}
        { mount|grep "on / type jffs2" 1>&-; } || firstboot
 }
 
-grep sysfs /proc/filesystems >&- 2>&- && {
-       mkdir -p /sys
-       mount -t sysfs none /sys
-}
-
 exec /sbin/init
index bd9b815e1256aeeecaa81188c256ae7da1f4710d..427ff0444ff06c3959d61dc6def73734213404d4 100755 (executable)
@@ -37,3 +37,4 @@ fi
 mount none /tmp -t tmpfs -o nosuid,nodev,mode=1777,size=50%
 mkdir -p /dev/pts
 mount none /dev/pts -t devpts
+grep sysfs /proc/filesystems >&- && mount -t sysfs none /sys