libtasn1:
authorOliver Ertl <oliver@ertl-net.net>
Thu, 6 Sep 2007 17:21:41 +0000 (17:21 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Thu, 6 Sep 2007 17:21:41 +0000 (17:21 +0000)
 * Update 0.2.13 > 1.1
 * Cleanup Makefile

SVN-Revision: 8655

libs/libtasn1/Makefile
libs/libtasn1/patches/500-cross-compile.patch [deleted file]

index f9ef740577407cd3236bb294dfe6e1fcb7160474..471e799087c3d3e6e8954c2e4b4f7a61c2ff7ec1 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,8 +9,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtasn1
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtasn1
-PKG_VERSION:=0.2.13
-PKG_RELEASE:=0
+PKG_VERSION:=1.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/libtasn1/ \
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/libtasn1/ \
@@ -18,11 +18,7 @@ PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/libtasn1/ \
        http://www.mirrors.wiretapped.net/security/network-security/gnutls/libtasn1/ \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/libtasn1/ \
        http://josefsson.org/gnutls/releases/libtasn1/
        http://www.mirrors.wiretapped.net/security/network-security/gnutls/libtasn1/ \
        ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/libtasn1/ \
        http://josefsson.org/gnutls/releases/libtasn1/
-PKG_MD5SUM:=d124b11908cfb88883fe71472c25d53a
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=93b43cc5013bda4d8bf64508f1566c54
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,31 +26,26 @@ define Package/libtasn1
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=An ASN.1 and DER structures manipulation library
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=An ASN.1 and DER structures manipulation library
-  DESCRIPTION:=\
-       This is a library for Abstract Syntax Notation One (ASN.1) and \\\
-       Distinguish Encoding Rules (DER) manipulation.
   URL:=ftp://ftp.gnutls.org/pub/gnutls/libtasn1/
 endef
 
   URL:=ftp://ftp.gnutls.org/pub/gnutls/libtasn1/
 endef
 
+define Package/libtasn1/description
+ This is a library for Abstract Syntax Notation One (ASN.1) and 
+ Distinguish Encoding Rules (DER) manipulation.
+endef
+
 define Build/Configure
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); touch \
-               configure.ac \
-               acinclude.m4 \
-               aclocal.m4 \
-               Makefile.in \
-               config.h.in \
-               configure \
-       );
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
        )
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
        )
+       $(call libtool_disable_rpath)
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(MAKE) -C $(PKG_BUILD_DIR) all
+       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
@@ -64,8 +55,8 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libtasn1.h $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtasn1.{a,so*} $(STAGING_DIR)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libtasn1.h $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtasn1.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/share/aclocal
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libtasn1.m4 $(STAGING_DIR)/usr/share/aclocal/
+       $(SED) 's,-I$$$${prefix}/include,,g' $(STAGING_DIR)/usr/bin/libtasn1-config
+       $(SED) 's,-L$$$${exec_prefix}/lib,,g' $(STAGING_DIR)/usr/bin/libtasn1-config
 endef
 
 define Build/UninstallDev
 endef
 
 define Build/UninstallDev
diff --git a/libs/libtasn1/patches/500-cross-compile.patch b/libs/libtasn1/patches/500-cross-compile.patch
deleted file mode 100644 (file)
index dadbf2b..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -ruN libtasn1-0.2.13-orig/configure libtasn1-0.2.13-1/configure
---- libtasn1-0.2.13-orig/configure     2004-12-15 19:40:02.000000000 +0100
-+++ libtasn1-0.2.13-1/configure        2005-03-15 22:35:56.000000000 +0100
-@@ -22448,8 +22448,8 @@
--LIBTASN1_LIBS="-L${libdir} -ltasn1 $LIBS"
--LIBTASN1_CFLAGS="-I${includedir}"
-+LIBTASN1_LIBS="-ltasn1 $LIBS"
-+LIBTASN1_CFLAGS=""
-diff -ruN libtasn1-0.2.13-orig/configure.in libtasn1-0.2.13-1/configure.in
---- libtasn1-0.2.13-orig/configure.in  2004-12-15 19:39:01.000000000 +0100
-+++ libtasn1-0.2.13-1/configure.in     2005-03-15 22:35:46.000000000 +0100
-@@ -85,8 +85,8 @@
- ])
- AM_PROG_LIBTOOL
--LIBTASN1_LIBS="-L${libdir} -ltasn1 $LIBS"
--LIBTASN1_CFLAGS="-I${includedir}"
-+LIBTASN1_LIBS="-ltasn1 $LIBS"
-+LIBTASN1_CFLAGS=""
- AC_SUBST(LIBTASN1_LIBS)
- AC_SUBST(LIBTASN1_CFLAGS)