Make ltq-dsl-app compile with an eglibc-based toolchain
authorMirko Vogt <mirko@openwrt.org>
Mon, 3 Dec 2012 12:46:57 +0000 (12:46 +0000)
committerMirko Vogt <mirko@openwrt.org>
Mon, 3 Dec 2012 12:46:57 +0000 (12:46 +0000)
Signed-Off-By: Frank Meerkötter <frank@meerkoetter.org>
SVN-Revision: 34468

package/network/config/ltq-dsl-app/Makefile
package/network/config/ltq-dsl-app/patches/010-eglibc_compile_fix.patch [new file with mode: 0644]

index 664bc5d8e142c48c113de4ad48ac86e702ad150a..37a72ee336b42b0b5202325593cee1822301738e 100644 (file)
@@ -17,6 +17,8 @@ PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
 PKG_MD5SUM:=ee315306626b68794d3d3636dabfe161
 PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 
+PKG_FIXUP:=autoreconf
+
 PKG_CONFIG_DEPENDS:=\
        CONFIG_LTQ_DSL_ENABLE_SOAP \
        CONFIG_LTQ_DSL_ENABLE_DSL_EVENT_POLLING
diff --git a/package/network/config/ltq-dsl-app/patches/010-eglibc_compile_fix.patch b/package/network/config/ltq-dsl-app/patches/010-eglibc_compile_fix.patch
new file mode 100644 (file)
index 0000000..268f868
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/configure.in
++++ b/configure.in
+@@ -29,6 +29,8 @@ AC_C_VOLATILE
+ #AC_FUNC_STRTOD
+ #AC_CHECK_FUNCS([ftime gethostbyname gettimeofday localtime_r memset select socket strchr strerror strstr strtoull])
++AC_SEARCH_LIBS([clock_gettime],[rt])
++
+ #
+ # save the configure arguments
+ #
+--- a/src/dsl_cpe_linux.h
++++ b/src/dsl_cpe_linux.h
+@@ -45,7 +45,8 @@
+ #include <arpa/inet.h>
+ #include <sys/socket.h>          /* socket */
+ #include <sys/sem.h>             /* semget */
+-#include <semaphore.h>           /* sem_t */ 
++#include <semaphore.h>           /* sem_t */
++#include <limits.h>
+ #ifdef DSL_DEBUG_TOOL_INTERFACE
+ #include <sys/socket.h>