[packages] reintroduce fakeidentd (#11559)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Jul 2012 11:04:16 +0000 (11:04 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Jul 2012 11:04:16 +0000 (11:04 +0000)
In the transition from WhiteRussian to Kamikaze, the fakeidentd package was dropped, citing its incorporation into the updated Busybox. However, the Busybox implementation doesn't support the -r switch, which is a bit silly,
since it's pretty much fakeidentd's raison d'etre. This patch restores the fakeidentd package, with an initscript that uses the -r option.

SVN-Revision: 32566

net/fakeidentd/Makefile [new file with mode: 0644]
net/fakeidentd/files/fakeidentd.init [new file with mode: 0644]

diff --git a/net/fakeidentd/Makefile b/net/fakeidentd/Makefile
new file mode 100644 (file)
index 0000000..0061078
--- /dev/null
@@ -0,0 +1,46 @@
+# 
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fakeidentd
+PKG_VERSION:=2.6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).c
+PKG_SOURCE_URL:=http://distfiles.gentoo.org/distfiles/
+PKG_MD5SUM:=d26693c1a7c883d1432e05fb6f7ead6e
+UNPACK_CMD=$(CP) $(DL_DIR)/$(PKG_SOURCE) $(1)/
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/fakeidentd
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=A static, secure identd.
+  URL:=http://www.guru-group.fi/~too/sw/releases/
+endef
+
+define Package/fakeidentd/description
+       A static secure identd, only one source file.
+endef
+
+define Build/Compile
+       $(SHELL) "$(PKG_BUILD_DIR)/$(MAKE_PATH)/$(PKG_SOURCE)" \
+       CC="$(TARGET_CC)" TRG="$(PKG_BUILD_DIR)/$(MAKE_PATH)/$(PKG_NAME)" \
+       $(TARGET_CFLAGS) $(EXTRA_CFLAGS) $(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS) \
+       $(TARGET_LDFLAGS) $(EXTRA_LDFLAGS) -DUSE_UNIX_OS 
+endef
+
+define Package/fakeidentd/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
+endef
+
+$(eval $(call BuildPackage,fakeidentd))
diff --git a/net/fakeidentd/files/fakeidentd.init b/net/fakeidentd/files/fakeidentd.init
new file mode 100644 (file)
index 0000000..4959ef2
--- /dev/null
@@ -0,0 +1,12 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006-2012 OpenWrt.org
+
+START=85
+
+start() {
+       service_start /usr/sbin/fakeidentd -r
+}
+
+stop() {
+       service_stop /usr/sbin/fakeidentd
+}