kernel: add thermal modules
authorLuka Perkov <luka@openwrt.org>
Fri, 27 Sep 2013 10:49:33 +0000 (10:49 +0000)
committerLuka Perkov <luka@openwrt.org>
Fri, 27 Sep 2013 10:49:33 +0000 (10:49 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38230

package/kernel/linux/modules/other.mk

index 293e51782191cda1c35a609d22e2bde4e37e17b7..cbce02bbf5d2b135edad8c276c92eb61b528bd7b 100644 (file)
@@ -760,3 +760,66 @@ define KernelPackage/random-core/description
 endef
 
 $(eval $(call KernelPackage,random-core))
+
+
+define KernelPackage/thermal
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Generic Thermal sysfs driver
+  KCONFIG:= \
+       CONFIG_THERMAL \
+       CONFIG_THERMAL_DEFAULT_GOV_STEP_WISE=y \
+       CONFIG_THERMAL_DEFAULT_GOV_FAIR_SHARE=n \
+       CONFIG_THERMAL_DEFAULT_GOV_USER_SPACE=n \
+       CONFIG_THERMAL_GOV_FAIR_SHARE=n \
+       CONFIG_THERMAL_GOV_STEP_WISE=y \
+       CONFIG_THERMAL_GOV_USER_SPACE=n \
+       CONFIG_THERMAL_EMULATION=n
+  FILES:=$(LINUX_DIR)/drivers/thermal/thermal_sys.ko
+  AUTOLOAD:=$(call AutoProbe,thermal_sys)
+endef
+
+define KernelPackage/thermal/description
+ Generic Thermal Sysfs driver offers a generic mechanism for thermal
+ management. Usually it's made up of one or more thermal zone and cooling
+ device.
+endef
+
+$(eval $(call KernelPackage,thermal))
+
+
+define KernelPackage/thermal-armada
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Armada 370/XP thermal management
+  DEPENDS:=@TARGET_mvebu +kmod-thermal
+  KCONFIG:=CONFIG_ARMADA_THERMAL
+  FILES:=$(LINUX_DIR)/drivers/thermal/armada_thermal.ko
+  AUTOLOAD:=$(call AutoProbe,armada_thermal)
+endef
+
+define KernelPackage/thermal-armada/description
+ Enable this module if you want to have support for thermal management
+ controller present in Armada 370 and Armada XP SoC.
+endef
+
+$(eval $(call KernelPackage,thermal-armada))
+
+
+define KernelPackage/thermal-imx
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Temperature sensor driver for Freescale i.MX SoCs
+  DEPENDS:=@TARGET_imx6 +kmod-thermal
+  KCONFIG:= \
+       CONFIG_CPU_THERMAL=y \
+       CONFIG_IMX_THERMAL
+  FILES:=$(LINUX_DIR)/drivers/thermal/imx_thermal.ko
+  AUTOLOAD:=$(call AutoProbe,imx_thermal)
+endef
+
+define KernelPackage/thermal-imx/description
+ Support for Temperature Monitor (TEMPMON) found on Freescale i.MX SoCs.
+ It supports one critical trip point and one passive trip point. The
+ cpufreq is used as the cooling device to throttle CPUs when the
+ passive trip is crossed.
+endef
+
+$(eval $(call KernelPackage,thermal-imx))