[backfire] cleanup: remove refs to unsupported "ps3" target
authorNicolas Thill <nico@openwrt.org>
Wed, 23 Nov 2011 21:44:30 +0000 (21:44 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 23 Nov 2011 21:44:30 +0000 (21:44 +0000)
SVN-Revision: 29304

package/ipset/Makefile
package/kernel/modules/block.mk
package/kernel/modules/sound.mk
package/mac80211/Makefile
package/siit/Makefile
package/wprobe/Makefile

index 7a2e8a1e8506ecb920c4a84d6b523ed5c79e68f3..4c3409b19bfb4de2b27f5e8a307f6cb247cf95fb 100644 (file)
@@ -19,7 +19,7 @@ PKG_MD5SUM:=d104007fdf5ea64fef774c22b1c0a97b
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ipset/Default
-  DEPENDS:= @LINUX_2_6 @(!(TARGET_ps3||TARGET_pxcab)||BROKEN)
+  DEPENDS:= @LINUX_2_6 @(!(TARGET_pxcab)||BROKEN)
 endef
 
 define Package/ipset
index 426f3c710294f9f6047057a38e1a9ab7aa24268e..159d9963801ea645ab42827e5d438098101b4c65 100644 (file)
@@ -449,21 +449,6 @@ endef
 
 $(eval $(call KernelPackage,aoe))
 
-define KernelPackage/ps3vram
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=PS3 Video RAM Storage Driver
-  DEPENDS:=@TARGET_ps3||TARGET_ps3chk
-  KCONFIG:=CONFIG_PS3_VRAM
-  FILES:=$(LINUX_DIR)/drivers/block/ps3vram.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,01,ps3vram)
-endef
-
-define KernelPackage/ps3vram/description
-  Kernel support for PS3 Video RAM Storage
-endef
-
-$(eval $(call KernelPackage,ps3vram))
-
 define KernelPackage/axonram
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Axon DDR2 memory device driver
index a3d1486346e1305c171d4fedc0efe194539cfc3f..847208d06695bf135eedee68541370acd66fd5e8 100644 (file)
@@ -100,23 +100,6 @@ endef
 $(eval $(call KernelPackage,sound-i8x0))
 
 
-define KernelPackage/sound-ps3
-$(call KernelPackage/sound/Depends,@TARGET_ps3||TARGET_ps3chk)
-  TITLE:=PS3 Audio
-  KCONFIG:=CONFIG_SND_PS3 \
-               CONFIG_SND_PPC=y \
-               CONFIG_SND_PS3_DEFAULT_START_DELAY=2000
-  FILES:=$(LINUX_DIR)/sound/ppc/snd_ps3.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,35, snd_ps3)
-endef
-
-define KernelPackage/sound-ps3/description
- support for the integrated PS3 audio device
-endef
-
-$(eval $(call KernelPackage,sound-ps3))
-
-
 define KernelPackage/sound-cs5535audio
 $(call KernelPackage/sound/Depends,@!TARGET_uml)
   TITLE:=CS5535 PCI Controller
index 35c2fa3db0495853d267e9b84812ef1480679e36..8a76b509e0c99c0afab3acc55312f57330e2018a 100644 (file)
@@ -48,7 +48,7 @@ define KernelPackage/mac80211/Default
   SUBMENU:=$(WMENU)
   URL:=http://linuxwireless.org/
   MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
-  DEPENDS:=@(!(TARGET_avr32||TARGET_ep93xx||TARGET_ps3||TARGET_pxcab)||BROKEN) @!LINUX_2_4
+  DEPENDS:=@(!(TARGET_avr32||TARGET_ep93xx||TARGET_pxcab)||BROKEN) @!LINUX_2_4
 endef
 
 define KernelPackage/cfg80211
index 4e9f94a8eed873b7f9a0ac5723d1c3237a7a1675..d8fa0ab9acf7f9d662d5e9375790439e42b7f03f 100644 (file)
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/package.mk
 define KernelPackage/siit
   SUBMENU:=Network Devices
   TITLE:=Stateless IP ICMP Translation Algorithm
-  DEPENDS:= @(!(TARGET_ps3||TARGET_pxcab)||BROKEN)
+  DEPENDS:= @(!(TARGET_pxcab)||BROKEN)
   FILES:=$(PKG_BUILD_DIR)/siit.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,siit)
 endef
index aafe731dc04e801a2dbd7077fe1613539c96db21..8cb3b2f610f7b93226dec1490778e22e20906b35 100644 (file)
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 # wprobe-lib.c:149: error: 'packed' attribute ignored for field of type 'struct <anonymous>'
 
 define Package/wprobe/Default
-  DEPENDS:=@LINUX_2_6 @(!(TARGET_ps3||TARGET_pxcab||cris)||BROKEN)
+  DEPENDS:=@LINUX_2_6 @(!(TARGET_pxcab||cris)||BROKEN)
 endef
 
 define KernelPackage/wprobe