[ar71xx/atheros] include revision number in Ubiquity images
authorFlorian Fainelli <florian@openwrt.org>
Fri, 20 Feb 2009 10:19:24 +0000 (10:19 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 20 Feb 2009 10:19:24 +0000 (10:19 +0000)
SVN-Revision: 14574

target/linux/ar71xx/image/Makefile
target/linux/atheros/image/Makefile

index 3f0cd01c7504b2387c39e05f03260eae02d98767..a48d5306d26c02b31df5f26cc17c5752ac0da090 100644 (file)
@@ -71,7 +71,7 @@ define Image/Build/UBNT
        $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).lzma
        dd if=$(KDIR)/vmlinux-$(2).lzma of=$(KDIR)/vmlinux-$(2).bin.lzma bs=64k conv=sync
        -$(STAGING_DIR_HOST)/bin/mkfwimage \
-               -B $(4) -v $(5).ar7100.OpenWrt \
+               -B $(4) -v $(5).ar7100.OpenWrt.$(REVISION) \
                -k $(KDIR)/vmlinux-$(2).bin.lzma \
                -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
                -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt-$(2)-$(1).bin
index 45b72c7a8770bdb06cd8f729321deab084c226b0..73657334ee863da7c2c87a4d6657f5ebc2c0742f 100644 (file)
@@ -24,13 +24,13 @@ define Image/Build
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
 
        -$(STAGING_DIR_HOST)/bin/mkfwimage \
-               -B XS2 -v XS2.ar2316.OpenWrt \
+               -B XS2 -v XS2.ar2316.OpenWrt.$(REVISION) \
                -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
                -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
                -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt2-$(1).bin
 
        -$(STAGING_DIR_HOST)/bin/mkfwimage \
-               -B XS5 -v XS5.ar2313.OpenWrt \
+               -B XS5 -v XS5.ar2313.OpenWrt.$(REVISION) \
                -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
                -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
                -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin