[package] kernel: add kmod-crypto-user
authorFlorian Fainelli <florian@openwrt.org>
Wed, 17 Aug 2011 08:48:38 +0000 (08:48 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 17 Aug 2011 08:48:38 +0000 (08:48 +0000)
Add kernel crypto user-space interface (af_alg). Includes interface for
hash algorithms (algif_hash) and skcipher algorithms (algif_skcipher).

Signed-off-by: Lars Hjersted <lars@hjersted.com>
SVN-Revision: 28026

package/kernel/modules/crypto.mk

index c7bbce97829b4493e6ea3d4991599533aea002d1..fc4865f6adc3d4b0428ec1beef92d62e78dc167e 100644 (file)
@@ -62,6 +62,22 @@ define KernelPackage/crypto-manager
 endef
 $(eval $(call KernelPackage,crypto-manager))
 
 endef
 $(eval $(call KernelPackage,crypto-manager))
 
+define KernelPackage/crypto-user
+  TITLE:=CryptoAPI userspace interface
+  DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager @LINUX_2_6_38||LINUX_2_6_39||LINUX_3_0
+  KCONFIG:= \
+       CONFIG_CRYPTO_USER_API \
+       CONFIG_CRYPTO_USER_API_HASH \
+       CONFIG_CRYPTO_USER_API_SKCIPHER
+  FILES:= \
+       $(LINUX_DIR)/crypto/af_alg.ko \
+       $(LINUX_DIR)/crypto/algif_hash.ko \
+       $(LINUX_DIR)/crypto/algif_skcipher.ko
+  AUTOLOAD:=$(call AutoLoad,09,af_alg algif_hash algif_skcipher)
+  $(call AddDepends/crypto)
+endef
+$(eval $(call KernelPackage,crypto-user))
+
 define KernelPackage/crypto-wq
   TITLE:=CryptoAPI work queue handling
   KCONFIG:=CONFIG_CRYPTO_WORKQUEUE
 define KernelPackage/crypto-wq
   TITLE:=CryptoAPI work queue handling
   KCONFIG:=CONFIG_CRYPTO_WORKQUEUE