More X package dependecy fixes.
authorLars-Peter Clausen <lars@metafoo.de>
Wed, 3 Sep 2008 21:59:13 +0000 (21:59 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Wed, 3 Sep 2008 21:59:13 +0000 (21:59 +0000)
SVN-Revision: 12523

XOrg/app/packages
XOrg/app/template.mk
XOrg/app/xcalc/Makefile
XOrg/app/xclipboard/Makefile
XOrg/app/xdm/Makefile
XOrg/app/xeyes/Makefile
XOrg/app/xinit/Makefile
XOrg/app/xlogo/Makefile
XOrg/app/xmessage/Makefile
XOrg/app/xset/Makefile
XOrg/app/xsetroot/Makefile

index 904bfa1e255bc8b902e35d09f7159a2b78b15ff3..8237c16c47205edfbd3b625ef25a0af8379104b6 100644 (file)
@@ -1,9 +1,9 @@
-xcalc-1.0.2|+font-misc-misc
-xclipboard-1.0.1|
-xdm-1.1.6|
-xeyes-1.0.1|
-xinit-1.0.5|
-xlogo-1.0.1|
-xmessage-1.0.2|
-xset-1.0.3|
-xsetroot-1.0.2|
+xcalc-1.0.2|+libX11+font-misc-misc
+xclipboard-1.0.1|+libX11
+xdm-1.1.6|+libX11
+xeyes-1.0.1|+libX11
+xinit-1.0.5|+libX11
+xlogo-1.0.1|+libX11
+xmessage-1.0.2|+libX11
+xset-1.0.3|+libX11
+xsetroot-1.0.2|+libX11
index d6d18690b295b3a46e07c417269dcc42a164fe25..d65055872f868ab7f178f5c1cab28d66fe905e29 100644 (file)
@@ -14,7 +14,7 @@ PKG_RELEASE:=2
 PKG_VERSION:=@VER@
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/app
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
+PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
 
 _DEPEND:=@DEP@
 ifneq (@NAME@,xinit)
index 7220d06efbd8a1d7ba4275299b09e8e08f515d02..d2abb1bf3a97cf27c07105225cae45079059dec8 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/app
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
 
-_DEPEND:= +font-misc-misc
+_DEPEND:= +libX11 +font-misc-misc
 ifneq (xcalc,xinit)
 _DEPEND+=xorg-server-essentials
 endif
index a09155c3dd10beba60d735ef58ff1ef2c4b79b5d..7eab19146c91231f267542a4146cb185cefe39a6 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/app
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
 
-_DEPEND:=
+_DEPEND:= +libX11
 ifneq (xclipboard,xinit)
 _DEPEND+=xorg-server-essentials
 endif
index 3b45e4dfe590291ff143549e2829a9b5749f2e1d..169a3c1efcf34d32ea335898816c2703b209cb3f 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/app
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
 
-_DEPEND:=
+_DEPEND:= +libX11
 ifneq (xdm,xinit)
 _DEPEND+=xorg-server-essentials
 endif
index 3acc212eac0005a81cf85d3c0ebae026356e2c93..d0c6b7e522b951837099cc38665e7e248fda9ab6 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/app
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
 
-_DEPEND:=
+_DEPEND:= +libX11
 ifneq (xeyes,xinit)
 _DEPEND+=xorg-server-essentials
 endif
index 94d9bbb0597a524b60052b5fa95715dc9f338971..1fcd55cb2e2fd9a5809eee0236967240ba7407a0 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/app
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
 
-_DEPEND:=
+_DEPEND:= +libX11
 ifneq (xinit,xinit)
 _DEPEND+=xorg-server-essentials
 endif
index dbf4ddb54dcece0207664329e15679cf15303d36..f0a261815f9bd60ecd13d7a01cc2914887ad5009 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/app
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
 
-_DEPEND:=
+_DEPEND:= +libX11
 ifneq (xlogo,xinit)
 _DEPEND+=xorg-server-essentials
 endif
index 91f17f0299a894e719a4fc79fe58a1dbb715eff0..5e4db1c577f6040ed6c290edc98a1caf5f8621c1 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/app
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
 
-_DEPEND:=
+_DEPEND:= +libX11
 ifneq (xmessage,xinit)
 _DEPEND+=xorg-server-essentials
 endif
index bad4d2a71f5cd86a0d20fa23cc89afd291bdff55..dbab0be71b27572159c7071b69b462267c41898a 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/app
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
 
-_DEPEND:=
+_DEPEND:= +libX11
 ifneq (xset,xinit)
 _DEPEND+=xorg-server-essentials
 endif
index ea2a64a6531740fb0b941e8c3c0523eb7fada0d0..bad5149b10088a97d4ab5420b6c27bcc74bd8353 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/app
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
 
-_DEPEND:=
+_DEPEND:= +libX11
 ifneq (xsetroot,xinit)
 _DEPEND+=xorg-server-essentials
 endif