[packages] lighttpd: add a patch fixing upstream issue [http://redmine.lighttpd.net...
authorNicolas Thill <nico@openwrt.org>
Tue, 30 Mar 2010 12:04:24 +0000 (12:04 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 30 Mar 2010 12:04:24 +0000 (12:04 +0000)
SVN-Revision: 20600

net/lighttpd/Makefile
net/lighttpd/patches/001-issue_2157.patch [new file with mode: 0644]

index 129936748d97a17fc9c3fea2f954b5738ebb9cf9..423c8cc72e75621be0033fa23c6836d935b5a7c7 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
 PKG_VERSION:=1.4.26
 
 PKG_NAME:=lighttpd
 PKG_VERSION:=1.4.26
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x/
diff --git a/net/lighttpd/patches/001-issue_2157.patch b/net/lighttpd/patches/001-issue_2157.patch
new file mode 100644 (file)
index 0000000..8cb3a3f
--- /dev/null
@@ -0,0 +1,13 @@
+http://redmine.lighttpd.net/issues/2157
+
+--- a/src/network.c
++++ b/src/network.c
+@@ -525,7 +525,7 @@ int network_init(server *srv) {
+               if (!s->ssl_use_sslv2) {
+                       /* disable SSLv2 */
+-                      if (SSL_OP_NO_SSLv2 != SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2)) {
++                      if (!(SSL_OP_NO_SSLv2 & SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2))) {
+                               log_error_write(srv, __FILE__, __LINE__, "ss", "SSL:",
+                                               ERR_error_string(ERR_get_error(), NULL));
+                               return -1;