include/cmake.mk: Add helper macro to handle conditionals for CMake boolean type...
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 13 Apr 2016 20:21:38 +0000 (20:21 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 13 Apr 2016 20:21:38 +0000 (20:21 +0000)
Signed-off-by: Vasilis Tsiligiannis <acinonyx@openwrt.gr>
SVN-Revision: 49164

include/cmake.mk

index a15cf3a671f49209f7e330d8d1c990c88ae8c3e7..009c6c27728e52eec7131952149232bfa7e60168 100644 (file)
@@ -1,3 +1,5 @@
+cmake_bool = $(patsubst %,-D%:BOOL=$(if $($(1)),ON,OFF),$(2))
+
 PKG_INSTALL:=1
 
 ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
 PKG_INSTALL:=1
 
 ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)