[backfire] ar71xx: Add generic Buffalo WZR-HP-G30XNH support
authorJonas Gorski <jogo@openwrt.org>
Thu, 28 Jul 2011 12:20:28 +0000 (12:20 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 28 Jul 2011 12:20:28 +0000 (12:20 +0000)
Use generic switch0 to add support for both WZR-HP-G301NH and WZR-HP-G300NH
with RTL8366RB.

SVN-Revision: 27816

target/linux/ar71xx/base-files/etc/defconfig/wzr-hp-g300nh/network
target/linux/ar71xx/files/arch/mips/ar71xx/mach-wzr-hp-g300nh.c
target/linux/ar71xx/profiles/buffalo.mk

index 48477fab195b0284e053fe3a4c0f5eaf957b1241..f274aa374e2952eadc0ec678273e136057239d50 100644 (file)
@@ -16,11 +16,11 @@ config interface wan
        option proto    dhcp
 
 config switch
-       option name     rtl8366s
+       option name     switch0
        option reset    1
        option enable_vlan 1
 
 config switch_vlan
-       option device   rtl8366s
+       option device   switch0
        option vlan     1
        option ports    "0 1 2 3 5"
index 8ba0ee39b14bcd43ae28a0ddcff645478d77ccf7..66009a109f093f1ff68c0d08fa234905d9a82610 100644 (file)
@@ -225,7 +225,7 @@ static struct platform_device wzrhpg300nh_rtl8366s_device = {
        }
 };
 
-static struct platform_device wzrhpg301nh_rtl8366rb_device = {
+static struct platform_device wzrhpg300nh_rtl8366rb_device = {
        .name           = RTL8366RB_DRIVER_NAME,
        .id             = -1,
        .dev = {
@@ -245,9 +245,9 @@ static void __init wzrhpg300nh_setup(void)
 
        if (hasrtl8366rb) {
                ar71xx_eth0_pll_data.pll_1000 = 0x1f000000;
-               ar71xx_eth0_data.mii_bus_dev = &wzrhpg301nh_rtl8366rb_device.dev;
+               ar71xx_eth0_data.mii_bus_dev = &wzrhpg300nh_rtl8366rb_device.dev;
                ar71xx_eth1_pll_data.pll_1000 = 0x100;
-               ar71xx_eth1_data.mii_bus_dev = &wzrhpg301nh_rtl8366rb_device.dev;
+               ar71xx_eth1_data.mii_bus_dev = &wzrhpg300nh_rtl8366rb_device.dev;
        } else {
                ar71xx_eth0_pll_data.pll_1000 = 0x1e000100;
                ar71xx_eth0_data.mii_bus_dev = &wzrhpg300nh_rtl8366s_device.dev;
index 69819e586dfa9c2fd3d61f265935af3a1b628650..ffaa0c58dc21e4592049d19914a9605b5435b3c6 100644 (file)
@@ -11,7 +11,7 @@ define Profile/WZRHPG300NH
 endef
 
 define Profile/WZRHPG300NH/Description
-       Package set optimized for the Buffalo WZR-HP-G300NH
+       Package set optimized for the Buffalo WZR-HP-G300NH and WZR-HP-G301NH
 endef
 
 $(eval $(call Profile,WZRHPG300NH))