[package] opennhrp: update to 0.12.3
authorFlorian Fainelli <florian@openwrt.org>
Fri, 30 Sep 2011 12:49:00 +0000 (12:49 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 30 Sep 2011 12:49:00 +0000 (12:49 +0000)
Signed-off-by: Artem Makhutov <artem@makhutov.org>
SVN-Revision: 28324

net/opennhrp/Makefile
net/opennhrp/patches/100-compile-fix.patch [deleted file]

index 4e3e0578ca0b42921858e1849c9702505a8c769b..3881b21e85ef82f10c49c35d1c239d663fc54153 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opennhrp
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opennhrp
-PKG_VERSION:=0.11.3
+PKG_VERSION:=0.12.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/opennhrp
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/opennhrp
-PKG_MD5SUM:=6f6f8571ccc0a9f97e52c6240fe9002a
+PKG_MD5SUM:=4d0ec7c0282e181ecca4d78e52067da3
 
 PKG_FIXUP:=libtool
 PKG_BUILD_PARALLEL:=1
 
 PKG_FIXUP:=libtool
 PKG_BUILD_PARALLEL:=1
@@ -49,6 +49,7 @@ define Package/opennhrp/install
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/opennhrp/opennhrp.conf $(1)/etc/opennhrp/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/opennhrp-script $(1)/etc/opennhrp/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/racoon-ph1down.sh $(1)/etc/opennhrp/
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/opennhrp/opennhrp.conf $(1)/etc/opennhrp/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/opennhrp-script $(1)/etc/opennhrp/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/racoon-ph1down.sh $(1)/etc/opennhrp/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/racoon-ph1dead.sh $(1)/etc/opennhrp/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/opennhrp.init $(1)/etc/init.d/opennhrp
 endef
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/opennhrp.init $(1)/etc/init.d/opennhrp
 endef
diff --git a/net/opennhrp/patches/100-compile-fix.patch b/net/opennhrp/patches/100-compile-fix.patch
deleted file mode 100644 (file)
index f822feb..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
----
- nhrp/sysdep_netlink.c |    1 +
- 1 file changed, 1 insertion(+)
-
---- opennhrp-0.11.3.orig/nhrp/sysdep_netlink.c
-+++ opennhrp-0.11.3/nhrp/sysdep_netlink.c
-@@ -26,6 +26,7 @@
- #include <asm/types.h>
- #include <linux/netlink.h>
- #include <linux/rtnetlink.h>
-+#include <linux/in6.h>
- #include <linux/ip.h>
- #include <linux/if_arp.h>
- #include <linux/if_tunnel.h>