adding python bindings for the "Enlightenment Foundation Libraries (EFL)"
authorMirko Vogt <mirko@openwrt.org>
Sun, 4 Jan 2009 13:26:36 +0000 (13:26 +0000)
committerMirko Vogt <mirko@openwrt.org>
Sun, 4 Jan 2009 13:26:36 +0000 (13:26 +0000)
SVN-Revision: 13858

lang/python-e_dbus/Makefile [new file with mode: 0644]
lang/python-e_dbus/patches/000-prevent-using-setuptools.patch [new file with mode: 0644]
lang/python-ecore/Makefile [new file with mode: 0644]
lang/python-ecore/patches/000-prevent-using-setuptools.patch [new file with mode: 0644]
lang/python-edje/Makefile [new file with mode: 0644]
lang/python-edje/patches/000-prevent-using-setuptools.patch [new file with mode: 0644]
lang/python-etk/Makefile [new file with mode: 0644]
lang/python-etk/patches/000-prevent-using-setuptools.patch [new file with mode: 0644]
lang/python-evas/Makefile [new file with mode: 0644]
lang/python-evas/patches/000-prevent-using-setuptools.patch [new file with mode: 0644]

diff --git a/lang/python-e_dbus/Makefile b/lang/python-e_dbus/Makefile
new file mode 100644 (file)
index 0000000..44a6a83
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 13786 2008-12-31 15:02:25Z lars $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-e_dbus
+
+PKG_REV:=37637
+PKG_VERSION:=r$(PKG_REV)
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://svn.enlightenment.org/svn/e/trunk/BINDINGS/python/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+
+define Package/python-e_dbus
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=python-e_dbus
+  DEPENDS:=python-core edbus dbus-python
+endef
+
+define Package/python-e_dbus/description
+  e_dbus python bindings
+endef
+
+define Build/Compile
+       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+endef
+
+define Package/python-e_dbus/install
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,python-e_dbus))
diff --git a/lang/python-e_dbus/patches/000-prevent-using-setuptools.patch b/lang/python-e_dbus/patches/000-prevent-using-setuptools.patch
new file mode 100644 (file)
index 0000000..0322955
--- /dev/null
@@ -0,0 +1,15 @@
+diff -ruN python-e_dbus-r37637.orig/setup.py python-e_dbus-r37637/setup.py
+--- python-e_dbus-r37637.orig/setup.py 2009-01-04 12:18:59.000000000 +0100
++++ python-e_dbus-r37637/setup.py      2009-01-04 12:21:26.000000000 +0100
+@@ -1,10 +1,7 @@
+ import sys
+ import os
+-from ez_setup import use_setuptools
+-use_setuptools("0.6c3")
+-
+-from setuptools import setup, Extension
++from distutils.core import setup, Extension
+ import subprocess
+ import shlex
diff --git a/lang/python-ecore/Makefile b/lang/python-ecore/Makefile
new file mode 100644 (file)
index 0000000..e2af2bc
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 13786 2008-12-31 15:02:25Z lars $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-ecore
+
+PKG_REV:=37637
+PKG_VERSION:=r$(PKG_REV)
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://svn.enlightenment.org/svn/e/trunk/BINDINGS/python/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+
+define Package/python-ecore
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=python-ecore
+  DEPENDS:=python-core ecore eina
+endef
+
+define Package/python-ecore/description
+  ecore python bindings
+endef
+
+define Build/Compile
+       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+endef
+
+define Package/python-ecore/install
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,python-ecore))
diff --git a/lang/python-ecore/patches/000-prevent-using-setuptools.patch b/lang/python-ecore/patches/000-prevent-using-setuptools.patch
new file mode 100644 (file)
index 0000000..8ff468f
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN python-ecore-r37637.orig/setup.py python-ecore-r37637/setup.py
+--- python-ecore-r37637.orig/setup.py  2009-01-04 12:06:41.000000000 +0100
++++ python-ecore-r37637/setup.py       2009-01-04 12:09:58.000000000 +0100
+@@ -1,10 +1,7 @@
+ import sys
+ import os
+-from ez_setup import use_setuptools
+-use_setuptools('0.6c3')
+-
+-from setuptools import setup, find_packages, Extension
++from distutils.core import setup, Extension
+ import subprocess
+ import shlex
+@@ -143,7 +140,7 @@
+       long_description=long_description,
+       keywords='wrapper binding enlightenment abstraction event ecore',
+       classifiers=trove_classifiers,
+-      packages=find_packages(),
++      packages=['ecore', 'ecore.x', 'ecore.evas', 'ecore.imf'],
+       install_requires=['python-evas>=0.3.1'],
+       setup_requires=['python-evas>=0.3.1'],
+       ext_modules=[ecoremodule, ecoreevasmodule, ecorexmodule,
diff --git a/lang/python-edje/Makefile b/lang/python-edje/Makefile
new file mode 100644 (file)
index 0000000..e137014
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 13786 2008-12-31 15:02:25Z lars $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-edje
+
+PKG_REV:=37637
+PKG_VERSION:=r$(PKG_REV)
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://svn.enlightenment.org/svn/e/trunk/BINDINGS/python/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+
+define Package/python-edje
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=python-edje
+  DEPENDS:=python-core edje
+endef
+
+define Package/python-edje/description
+  edje python bindings
+endef
+
+define Build/Compile
+       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+endef
+
+define Package/python-edje/install
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,python-edje))
diff --git a/lang/python-edje/patches/000-prevent-using-setuptools.patch b/lang/python-edje/patches/000-prevent-using-setuptools.patch
new file mode 100644 (file)
index 0000000..92cc17e
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN python-edje-r37637.orig/setup.py python-edje-r37637/setup.py
+--- python-edje-r37637.orig/setup.py   2009-01-04 11:55:43.000000000 +0100
++++ python-edje-r37637/setup.py        2009-01-04 11:57:55.000000000 +0100
+@@ -1,10 +1,7 @@
+ import sys
+ import os
+-from ez_setup import use_setuptools
+-use_setuptools('0.6c3')
+-
+-from setuptools import setup, find_packages, Extension
++from distutils.core import setup, Extension
+ import subprocess
+ import shlex
+@@ -128,7 +125,7 @@
+       long_description=long_description,
+       keywords='wrapper binding enlightenment graphics raster evas canvas theme',
+       classifiers=trove_classifiers,
+-      packages=find_packages(),
++      packages=['edje'],
+       install_requires=['python-evas>=0.3.1'],
+       setup_requires=['python-evas>=0.3.1'],
+       ext_modules=[edjemodule],
diff --git a/lang/python-etk/Makefile b/lang/python-etk/Makefile
new file mode 100644 (file)
index 0000000..71a0f7d
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 13786 2008-12-31 15:02:25Z lars $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-etk
+
+PKG_REV:=37637
+PKG_VERSION:=r$(PKG_REV)
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://svn.enlightenment.org/svn/e/trunk/BINDINGS/python/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+
+define Package/python-etk
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=python-etk
+  DEPENDS:=python-core etk
+endef
+
+define Package/python-etk/description
+  etk python bindings
+endef
+
+define Build/Compile
+       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+endef
+
+define Package/python-etk/install
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,python-etk))
diff --git a/lang/python-etk/patches/000-prevent-using-setuptools.patch b/lang/python-etk/patches/000-prevent-using-setuptools.patch
new file mode 100644 (file)
index 0000000..2accf71
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN python-etk-r37637.orig/setup.py python-etk-r37637/setup.py
+--- python-etk-r37637.orig/setup.py    2009-01-04 12:54:25.000000000 +0100
++++ python-etk-r37637/setup.py 2009-01-04 12:57:48.000000000 +0100
+@@ -1,10 +1,7 @@
+ import sys
+ import os
+-from ez_setup import use_setuptools
+-use_setuptools('0.6c3')
+-
+-from setuptools import setup, find_packages, Extension
++from distutils.core import setup, Extension
+ from distutils.sysconfig import get_python_inc
+ from glob import glob
+ import commands
+@@ -74,7 +71,7 @@
+       long_description = long_description,
+       keywords = 'wrapper binding ui etk graphics',
+       classifiers = trove_classifiers,
+-      packages = find_packages(),
++      packages = ['etk'],
+       install_requires = ['python-evas>=0.2.1', 'python-ecore>=0.2.1'],
+       setup_requires = ['python-evas>=0.2.1', 'python-ecore>=0.2.1'],
+       headers = headers,
diff --git a/lang/python-evas/Makefile b/lang/python-evas/Makefile
new file mode 100644 (file)
index 0000000..6854ee1
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 13786 2008-12-31 15:02:25Z lars $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-evas
+
+PKG_REV:=37637
+PKG_VERSION:=r$(PKG_REV)
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://svn.enlightenment.org/svn/e/trunk/BINDINGS/python/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+
+define Package/python-evas
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=python-evas
+  DEPENDS:=python-core evas eina
+endef
+
+define Package/python-evas/description
+  evas python bindings
+endef
+
+define Build/Compile
+       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+endef
+
+define Package/python-evas/install
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,python-evas))
diff --git a/lang/python-evas/patches/000-prevent-using-setuptools.patch b/lang/python-evas/patches/000-prevent-using-setuptools.patch
new file mode 100644 (file)
index 0000000..db9ac60
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN python-evas-r37637.orig/setup.py python-evas-r37637/setup.py
+--- python-evas-r37637.orig/setup.py   2009-01-03 02:04:31.000000000 +0100
++++ python-evas-r37637/setup.py        2009-01-04 11:50:39.000000000 +0100
+@@ -1,10 +1,7 @@
+ import sys
+ import os
+-from ez_setup import use_setuptools
+-use_setuptools('0.6c3')
+-
+-from setuptools import setup, find_packages, Extension
++from distutils.core import setup, Extension
+ from distutils.command.install_headers import install_headers
+ from distutils.sysconfig import get_python_inc
+ import subprocess
+@@ -142,7 +139,7 @@
+       long_description=long_description,
+       keywords='wrapper binding enlightenment graphics raster evas canvas',
+       classifiers=trove_classifiers,
+-      packages=find_packages(),
++      packages=['evas'],
+       headers=headers,
+       ext_modules=[evasmodule],
+       zip_safe=False,