[tools] mklibs: upgrade to 0.1.37
authorLuka Perkov <luka@openwrt.org>
Mon, 3 Jun 2013 01:18:45 +0000 (01:18 +0000)
committerLuka Perkov <luka@openwrt.org>
Mon, 3 Jun 2013 01:18:45 +0000 (01:18 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 36820

tools/mklibs/Makefile
tools/mklibs/patches/002-disable_symbol_checks.patch
tools/mklibs/patches/003-no_copy.patch
tools/mklibs/patches/004-libpthread_link.patch
tools/mklibs/patches/005-duplicate_syms.patch
tools/mklibs/patches/006-uclibc_init.patch
tools/mklibs/patches/007-gc_sections.patch
tools/mklibs/patches/008-uclibc_libgcc_link.patch
tools/mklibs/patches/009-uclibc_libpthread_symbols.patch
tools/mklibs/patches/010-remove_STT_GNU_IFUNC.patch
tools/mklibs/patches/011-remove_multiarch.patch

index fa0bce70d9bd509aa31a0a17a556e161b2bd9536..1f6ce27db518012d971214f0b8e303221152fd6d 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mklibs
-PKG_VERSION:=0.1.35
+PKG_VERSION:=0.1.37
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mklibs/
-PKG_MD5SUM:=3d2a4bd0bbf5ba964b0a1ecdafd1ea9a
+PKG_MD5SUM:=099cc99d51f09ea51e58a56e62a46af7
 
 HOST_FIXUP:=autoreconf
 
index 44be637609d7ff2247686cb8f1fd69b20fb6d4b5..4c0a362b36932a8b0b0d02a005757bbac8f99d2c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/mklibs
 +++ b/src/mklibs
-@@ -524,7 +524,7 @@ while 1:
+@@ -522,7 +522,7 @@
          # No progress in last pass. Verify all remaining symbols are weak.
          for name in unresolved:
              if not needed_symbols[name].weak:
@@ -9,7 +9,7 @@
          break
  
      previous_pass_unresolved = unresolved
-@@ -559,7 +559,7 @@ while 1:
+@@ -557,7 +557,7 @@
      for name in needed_symbols:
          if not name in symbol_provider:
              if not needed_symbols[name].weak:
index e0ab2ac88d198e0be480c157f6c875d3fb5fcde3..ba40570a032b462db76a1e98bbd40fb192296a08 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/mklibs
 +++ b/src/mklibs
-@@ -463,7 +463,7 @@ while 1:
+@@ -461,7 +461,7 @@
      passnr = passnr + 1
      # Gather all already reduced libraries and treat them as objects as well
      small_libs = []
@@ -9,7 +9,7 @@
          obj = dest_path + "/" + lib
          small_libs.append(obj)
          inode = os.stat(obj)[ST_INO]
-@@ -579,12 +579,7 @@ while 1:
+@@ -577,12 +577,7 @@
          if not so_file:
              sys.exit("File not found:" + library)
          pic_file = find_pic(library)
@@ -23,7 +23,7 @@
              # we have a pic file, recompile
              debug(DEBUG_SPAM, "extracting from:", pic_file, "so_file:", so_file)
              soname = extract_soname(so_file)
-@@ -627,22 +622,14 @@ while 1:
+@@ -625,22 +620,14 @@
              cmd.append(library_depends_gcc_libnames(so_file))
              command(target + "gcc", *cmd)
  
index 657e232b0cba4a7d21f216db2a5f13df141bd9cf..ccf134078373a8dddf0aaa573a7529648fb06f99 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/mklibs
 +++ b/src/mklibs
-@@ -106,14 +106,14 @@ def library_depends(obj):
+@@ -106,14 +106,14 @@
  
  # Return a list of libraries the passed objects depend on. The
  # libraries are in "-lfoo" format suitable for passing to gcc.
@@ -17,7 +17,7 @@
              if match.group('ld'):
                  ret.append(find_lib(match.group(0)))
              elif match.group('lib'):
-@@ -619,7 +619,7 @@ while 1:
+@@ -617,7 +617,7 @@
              cmd.extend(extra_flags)
              cmd.append("-lgcc")
              cmd.extend(["-L%s" % a for a in [dest_path] + [sysroot + b for b in lib_path if sysroot == "" or b not in ("/" + libdir + "/", "/usr/" + libdir + "/")]])
index 8428abfc9a07d278f92fdee168e1cc88f162cbb3..19ba0171d0e69237c4d96fc283505c622de3d182 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/mklibs
 +++ b/src/mklibs
-@@ -531,7 +531,6 @@ while 1:
+@@ -529,7 +529,6 @@
  
      library_symbols = {}
      library_symbols_used = {}
@@ -8,7 +8,7 @@
  
      # WORKAROUND: Always add libgcc on old-abi arm
      header = elf_header(find_lib(libraries.copy().pop()))
-@@ -549,20 +548,13 @@ while 1:
+@@ -547,20 +546,13 @@
          library_symbols_used[library] = set()
          for symbol in symbols:
              for name in symbol.base_names():
index 2df7fe43556e8ed5f20eb6063e1583cec51d9448..8a07e3360976b80e840363872113000e9fc6b81b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/mklibs
 +++ b/src/mklibs
-@@ -595,6 +595,11 @@ while 1:
+@@ -593,6 +593,11 @@
                  extra_post_obj.append(sysroot + libc_extras_dir + "/sofini.o")
                  symbols.add(ProvidedSymbol('__dso_handle', None, None, True))
  
index 068d88a532aac67eb5832417021f8c85b1f5002c..0d47a1df092174f722490c7076453fc466ebb83e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/mklibs
 +++ b/src/mklibs
-@@ -607,7 +607,7 @@ while 1:
+@@ -605,7 +605,7 @@
              # compile in only used symbols
              cmd = []
              cmd.extend(gcc_options)
index 432a313b6c3d5b06d390ecaef169de7afa0505f1..7172b4ca5d27cec66018497662a20ccdbec0ffaa 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/mklibs
 +++ b/src/mklibs
-@@ -113,11 +113,8 @@ def library_depends_gcc_libnames(obj, so
+@@ -113,11 +113,8 @@
      ret = []
      for i in libs:
          match = re.match("^(((?P<ld>ld\S*)|(lib(?P<lib>\S+))))\.so.*$", i)
@@ -14,7 +14,7 @@
      return ' '.join(ret)
  
  class Symbol(object):
-@@ -584,6 +581,7 @@ while 1:
+@@ -582,6 +579,7 @@
              extra_flags = []
              extra_pre_obj = []
              extra_post_obj = []
@@ -22,7 +22,7 @@
  
              symbols.update(library_symbols_used[library])
  
-@@ -614,9 +612,10 @@ while 1:
+@@ -612,9 +610,10 @@
              cmd.append(pic_file)
              cmd.extend(extra_post_obj)
              cmd.extend(extra_flags)
index 34866f72905deb064542a461d181a139a4407def..ec679267a274ad1d8fc882afa8751f6b3a67fa5e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/mklibs
 +++ b/src/mklibs
-@@ -162,9 +162,10 @@ def undefined_symbols(obj):
+@@ -162,9 +162,10 @@
      return result
  
  class ProvidedSymbol(Symbol):
@@ -12,7 +12,7 @@
  
      def base_names(self):
          ret = []
-@@ -205,11 +206,15 @@ def provided_symbols(obj):
+@@ -205,11 +206,15 @@
          if version_string.lower() not in ('base', 'none'):
              version = version_string
  
@@ -29,7 +29,7 @@
  
      return result
      
-@@ -500,6 +505,9 @@ while 1:
+@@ -498,6 +503,9 @@
              debug(DEBUG_SPAM, "present_symbols adding %s" % symbol)
              names = symbol.base_names()
              for name in names:
@@ -39,7 +39,7 @@
                  present_symbols[name] = symbol
  
      # are we finished?
-@@ -591,12 +599,16 @@ while 1:
+@@ -589,12 +597,16 @@
                  # may segfault in ptmalloc_init due to undefined weak reference
                  extra_pre_obj.append(sysroot + libc_extras_dir + "/soinit.o")
                  extra_post_obj.append(sysroot + libc_extras_dir + "/sofini.o")
index 6bae8c7ce53c4f485f1b0b361534064e5bf938d5..6d3555816e901beaa27349d771797168085c9579 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/mklibs-readelf/main.cpp
 +++ b/src/mklibs-readelf/main.cpp
-@@ -84,7 +84,7 @@ static void process_symbols_provided (co
+@@ -84,7 +84,7 @@
        continue;
      if (shndx == SHN_UNDEF || shndx == SHN_ABS)
        continue;
@@ -9,7 +9,7 @@
        continue;
      if (!name.size())
        continue;
-@@ -115,7 +115,7 @@ static void process_symbols_undefined (c
+@@ -115,7 +115,7 @@
        continue;
      if (shndx != SHN_UNDEF)
        continue;
index a32d8ee17a81842561081e01b13d5c76aa434893..9f0bdd11e678a1b0547a6b277512fe91cd169fe6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/mklibs
 +++ b/src/mklibs
-@@ -263,6 +263,7 @@ def extract_soname(so_file):
+@@ -263,6 +263,7 @@
      return ""
  
  def multiarch(paths):