[7701] for bcm43xx-mac80211 as well
authorFelix Fietkau <nbd@openwrt.org>
Fri, 22 Jun 2007 04:55:38 +0000 (04:55 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 22 Jun 2007 04:55:38 +0000 (04:55 +0000)
SVN-Revision: 7703

package/bcm43xx-mac80211/Makefile

index d423620430ef5c1d945c2ccc082758a78725a1cd..4725cd7e180bdce0c2850448cbb6b28f85adf74a 100644 (file)
@@ -32,8 +32,10 @@ define KernelPackage/bcm43xx-mac80211
   VERSION:=$(PKG_RELEASE)+$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
   DEPENDS:=@LINUX_2_6 +kmod-mac80211
   SUBMENU:=Wireless Drivers
+  ifneq ($(KERNEL_PATCHVER),2.6.21)
 #  AUTOLOAD:=$(call AutoLoad,30,bcm43xx-mac80211)
-  FILES:=$(PKG_BUILD_DIR)/bcm43xx-mac80211.$(LINUX_KMOD_SUFFIX)
+   FILES:=$(PKG_BUILD_DIR)/bcm43xx-mac80211.$(LINUX_KMOD_SUFFIX)
+  endif
 endef
 
 define Build/Prepare
@@ -41,13 +43,15 @@ define Build/Prepare
        $(CP) ./src/bcm43xx/* $(PKG_BUILD_DIR)/
 endef
 
-define Build/Compile
+ifneq ($(KERNEL_PATCHVER),2.6.21)
+  define Build/Compile
        $(MAKE) $(MAKE_CONFIGS) -C "$(LINUX_DIR)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                ARCH="$(LINUX_KARCH)" \
                EXTRA_CFLAGS="$(BUILDFLAGS)" \
                SUBDIRS="$(PKG_BUILD_DIR)" \
                modules
-endef
+  endef
+endif
 
 $(eval $(call KernelPackage,bcm43xx-mac80211))