remove stale patches, fixes ticket #1579
authorTim Yardley <lst@openwrt.org>
Tue, 10 Apr 2007 14:30:21 +0000 (14:30 +0000)
committerTim Yardley <lst@openwrt.org>
Tue, 10 Apr 2007 14:30:21 +0000 (14:30 +0000)
SVN-Revision: 6923

libs/postgresql/patches/100-debian-12asmconstraints [deleted file]
libs/postgresql/patches/101-debian-27dbf2pg-textfield [deleted file]
libs/postgresql/patches/102-debian-30libpq [deleted file]

diff --git a/libs/postgresql/patches/100-debian-12asmconstraints b/libs/postgresql/patches/100-debian-12asmconstraints
deleted file mode 100644 (file)
index f43eedc..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ruN postgresql-7.4.7-old/src/include/storage/s_lock.h postgresql-7.4.7/src/include/storage/s_lock.h
---- postgresql-7.4.7-old/src/include/storage/s_lock.h  2004-06-15 16:09:30.000000000 +0200
-+++ postgresql-7.4.7/src/include/storage/s_lock.h      2004-06-15 16:19:02.000000000 +0200
-@@ -125,7 +125,7 @@
-       __asm__ __volatile__(
-               "       xchg4   %0=%1,%2        \n"
- :             "=r"(ret), "=m"(*lock)
--:             "r"(1), "1"(*lock)
-+:             "r"(1), "m"(*lock)
- :             "memory");
-       return (int) ret;
-@@ -294,7 +294,7 @@
-               "       tas             %1              \n"
-               "       sne             %0              \n"
- :             "=d"(rv), "=m"(*lock)
--:             "1"(*lock)
-+:             "m"(*lock)
- :             "cc");
-       return rv;
diff --git a/libs/postgresql/patches/101-debian-27dbf2pg-textfield b/libs/postgresql/patches/101-debian-27dbf2pg-textfield
deleted file mode 100644 (file)
index a450771..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ruN postgresql-7.4.7-old/contrib/dbase/dbf2pg.c postgresql-7.4.7/contrib/dbase/dbf2pg.c
---- postgresql-7.4.7-old/contrib/dbase/dbf2pg.c        2004-10-31 20:09:10.923855000 +0100
-+++ postgresql-7.4.7/contrib/dbase/dbf2pg.c    2004-10-31 20:11:24.676521696 +0100
-@@ -324,6 +324,10 @@
-                       case 'L':
-                               strcat(query, " char");
-                               break;
-+
-+                      case 'M':
-+                              strcat(query, " text");
-+                              break;
-               }
-       }
diff --git a/libs/postgresql/patches/102-debian-30libpq b/libs/postgresql/patches/102-debian-30libpq
deleted file mode 100644 (file)
index 245b97f..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -ruN postgresql-7.4.7-old/src/interfaces/libpq/Makefile postgresql-7.4.7/src/interfaces/libpq/Makefile
---- postgresql-7.4.7-old/src/interfaces/libpq/Makefile 2003-08-23 05:21:59.000000000 +0100
-+++ postgresql-7.4.7/src/interfaces/libpq/Makefile     2003-08-29 18:35:25.000000000 +0100
-@@ -32,7 +32,7 @@
- SHLIB_LINK += $(filter -lcrypt -ldes -lkrb -lcom_err -lcrypto -lk5crypto -lkrb5 -lssl -lsocket -lnsl -lresolv -lintl, $(LIBS)) $(THREAD_LIBS)
--all: all-lib
-+all: all-lib libpq3-config
- # Shared library stuff
- include $(top_srcdir)/src/Makefile.shlib
-@@ -58,6 +58,8 @@
- encnames.c wchar.c : % : $(backend_src)/utils/mb/%
-       rm -f $@ && $(LN_S) $< .
-+libpq3-config:
-+      sed -e "s|%LIBRARIES%|$(SHLIB_LINK)|" <libpq3-config.in | sed "s/-L[^ ]\+ //" >libpq3-config
- install: all installdirs install-lib
-       $(INSTALL_DATA) $(srcdir)/libpq-fe.h $(DESTDIR)$(includedir)
-@@ -73,3 +75,4 @@
- clean distclean maintainer-clean: clean-lib
-       rm -f $(OBJS) crypt.c getaddrinfo.c inet_aton.c snprintf.c strerror.c path.c thread.c dllist.c md5.c ip.c encnames.c wchar.c
-+      rm -f libpq3-config
-diff -ruN postgresql-7.4.7-old/src/interfaces/libpq/libpq3-config.in postgresql-7.4.7/src/interfaces/libpq/libpq3-config.in
---- postgresql-7.4.7-old/src/interfaces/libpq/libpq3-config.in 1970-01-01 01:00:00.000000000 +0100
-+++ postgresql-7.4.7/src/interfaces/libpq/libpq3-config.in     2003-08-29 18:34:25.000000000 +0100
-@@ -0,0 +1,3 @@
-+#!/bin/bash
-+
-+echo %LIBRARIES%