fix path to apr-1-config & apu-1-config (closes: #3113)
authorNicolas Thill <nico@openwrt.org>
Sun, 13 Apr 2008 18:20:42 +0000 (18:20 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 13 Apr 2008 18:20:42 +0000 (18:20 +0000)
SVN-Revision: 10822

libs/apr-util/Makefile
libs/apr/Makefile
net/apache/Makefile
net/subversion/Makefile

index 6f09d2f48df5c7bea9023ac99ee0d4d06156ec28..1c933711da653ae51f28d721f92698cdaa942970 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -31,7 +31,7 @@ endef
 
 CONFIGURE_ARGS += \
        --with-pgsql=no \
 
 CONFIGURE_ARGS += \
        --with-pgsql=no \
-       --with-apr="$(STAGING_DIR)/host/bin/apr-1-config" \
+       --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
        --with-expat="$(STAGING_DIR)/usr" \
        --without-sqlite2 \
        --with-sqlite3="$(STAGING_DIR)/usr" \
        --with-expat="$(STAGING_DIR)/usr" \
        --without-sqlite2 \
        --with-sqlite3="$(STAGING_DIR)/usr" \
@@ -47,20 +47,20 @@ define Build/Compile
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(2)/bin $(1)/usr/include/apr-1/ $(1)/usr/lib  $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include/apr-1/ $(1)/usr/lib  $(1)/usr/lib/pkgconfig/
        $(CP)   $(PKG_INSTALL_DIR)/usr/bin/apu-1-config \
        $(CP)   $(PKG_INSTALL_DIR)/usr/bin/apu-1-config \
-               $(2)/bin
+               $(1)/usr/bin/
        $(CP)   $(PKG_INSTALL_DIR)/usr/include/apr-1/* \
                $(1)/usr/include/apr-1/
        $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.{la,a,so*} \
                $(1)/usr/lib/
        $(CP)   $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/apr-util-1.pc \
                $(1)/usr/lib/pkgconfig/
        $(CP)   $(PKG_INSTALL_DIR)/usr/include/apr-1/* \
                $(1)/usr/include/apr-1/
        $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.{la,a,so*} \
                $(1)/usr/lib/
        $(CP)   $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/apr-util-1.pc \
                $(1)/usr/lib/pkgconfig/
-       $(SED) 's, -e \"s -I$$$$prefix/lib  g\",,g' $(2)/bin/apu-1-config
-       $(SED) 's,^libdir=\"$$$${exec_prefix}/lib,libdir=\"$(STAGING_DIR)/usr/lib,g' $(2)/bin/apu-1-config
-       $(SED) 's,^includedir=\"$$$${prefix}/include/,includedir=\"$(STAGING_DIR)/usr/include/,g' $(2)/bin/apu-1-config
-       $(SED) 's,-L$$$$libdir,,g' $(2)/bin/apu-1-config
-       $(SED) 's,-R$$$$libdir,,g' $(2)/bin/apu-1-config
+       $(SED) 's, -e \"s -I$$$$prefix/lib  g\",,g' $(1)/usr/bin/apu-1-config
+       $(SED) 's,^libdir=\"$$$${exec_prefix}/lib,libdir=\"$(STAGING_DIR)/usr/lib,g' $(1)/usr/bin/apu-1-config
+       $(SED) 's,^includedir=\"$$$${prefix}/include/,includedir=\"$(STAGING_DIR)/usr/include/,g' $(1)/usr/bin/apu-1-config
+       $(SED) 's,-L$$$$libdir,,g' $(1)/usr/bin/apu-1-config
+       $(SED) 's,-R$$$$libdir,,g' $(1)/usr/bin/apu-1-config
 endef
 
 define Package/libaprutil/install      
 endef
 
 define Package/libaprutil/install      
index 61821162eaf0a30ad54e8f0983320aa47c84f19f..a9394dc7ac796deff93a4689b6f3588bb5b7b185 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -46,9 +46,9 @@ define Build/Compile
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(2)/bin $(1)/usr/include/apr-1 $(1)/usr/lib $(1)/usr/lib/pkgconfig $(1)/usr/share/build-1
+       $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include/apr-1 $(1)/usr/lib $(1)/usr/lib/pkgconfig $(1)/usr/share/build-1
        $(CP)   $(PKG_INSTALL_DIR)/usr/bin/apr-1-config \
        $(CP)   $(PKG_INSTALL_DIR)/usr/bin/apr-1-config \
-               $(2)/bin
+               $(1)/usr/bin/
        $(CP)   $(PKG_INSTALL_DIR)/usr/include/apr-1/* \
                $(1)/usr/include/apr-1/
        $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libapr-1.{la,a,so*} \
        $(CP)   $(PKG_INSTALL_DIR)/usr/include/apr-1/* \
                $(1)/usr/include/apr-1/
        $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libapr-1.{la,a,so*} \
@@ -57,12 +57,12 @@ define Build/InstallDev
                $(1)/usr/lib/pkgconfig/
        $(CP)   $(PKG_INSTALL_DIR)/usr/share/build-1/* \
                $(1)/usr/share/build-1/
                $(1)/usr/lib/pkgconfig/
        $(CP)   $(PKG_INSTALL_DIR)/usr/share/build-1/* \
                $(1)/usr/share/build-1/
-       $(SED) 's,^datadir=\"/usr/share\",datadir=\"$(STAGING_DIR)/usr/share\",g' $(2)/bin/apr-1-config
-       $(SED) 's,^installbuilddir=\"/usr/share/build-1\",installbuilddir=\"$(STAGING_DIR)/usr/share/build-1\",g' $(2)/bin/apr-1-config
-       $(SED) 's,^libdir=\"$$$${exec_prefix}/lib,libdir=\"$(STAGING_DIR)/usr/lib,g' $(2)/bin/apr-1-config
-       $(SED) 's,^includedir=\"$$$${prefix}/include/,includedir=\"$(STAGING_DIR)/usr/include/,g' $(2)/bin/apr-1-config
-       $(SED) 's,-L$$$$libdir,,g' $(2)/bin/apr-1-config
-       $(SED) 's,-R$$$$libdir,,g' $(2)/bin/apr-1-config
+       $(SED) 's,^datadir=\"/usr/share\",datadir=\"$(STAGING_DIR)/usr/share\",g' $(1)/usr/bin/apr-1-config
+       $(SED) 's,^installbuilddir=\"/usr/share/build-1\",installbuilddir=\"$(STAGING_DIR)/usr/share/build-1\",g' $(1)/usr/bin/apr-1-config
+       $(SED) 's,^libdir=\"$$$${exec_prefix}/lib,libdir=\"$(STAGING_DIR)/usr/lib,g' $(1)/usr/bin/apr-1-config
+       $(SED) 's,^includedir=\"$$$${prefix}/include/,includedir=\"$(STAGING_DIR)/usr/include/,g' $(1)/usr/bin/apr-1-config
+       $(SED) 's,-L$$$$libdir,,g' $(1)/usr/bin/apr-1-config
+       $(SED) 's,-R$$$$libdir,,g' $(1)/usr/bin/apr-1-config
        $(SED) 's,/usr/share/build-1,$(STAGING_DIR)/usr/share/build-1,g' $(1)/usr/share/build-1/apr_rules.mk
 endef
 
        $(SED) 's,/usr/share/build-1,$(STAGING_DIR)/usr/share/build-1,g' $(1)/usr/share/build-1/apr_rules.mk
 endef
 
index 47dbcd065866c9b004478fbef56f6fba7fc212b4..9fd291cca5c5aba2c4105ca57dc7415551bd8f2f 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -80,9 +80,9 @@ endef
 
 define Build/Configure 
        $(call Build/Configure/Default, \
 
 define Build/Configure 
        $(call Build/Configure/Default, \
-               --with-apr="$(STAGING_DIR)/host/bin/apr-1-config" \
-               --with-apr-util="$(STAGING_DIR)/host/bin/apu-1-config" \
-               --with-pcre="$(STAGING_DIR)/host/bin/pcre-config" \
+               --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
+               --with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \
+               --with-pcre="$(STAGING_DIR)/usr/bin/pcre-config" \
                --enable-http \
                --enable-ssl \
                --enable-proxy \
                --enable-http \
                --enable-ssl \
                --enable-proxy \
index d26cce30dbaddfe60751ad7d239f6bbcdbd360ea..ca3ef2d28a6e20cc977242c314aff863a8a242d9 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -47,8 +47,8 @@ define Package/subversion-server
 endef
 
 CONFIGURE_ARGS += \
 endef
 
 CONFIGURE_ARGS += \
-       --with-apr="$(STAGING_DIR)/host/bin/apr-1-config" \
-       --with-apr-util="$(STAGING_DIR)/host/bin/apu-1-config" \
+       --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
+       --with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \
        --with-neon="$(STAGING_DIR)/usr/include/neon" \
        --disable-mod-activation \
        --without-ruby-sitedir \
        --with-neon="$(STAGING_DIR)/usr/include/neon" \
        --disable-mod-activation \
        --without-ruby-sitedir \