image: add a build step for building and appending an ubinized rootfs
authorJonas Gorski <jogo@openwrt.org>
Fri, 4 Sep 2015 14:44:10 +0000 (14:44 +0000)
committerJonas Gorski <jogo@openwrt.org>
Fri, 4 Sep 2015 14:44:10 +0000 (14:44 +0000)
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46783

include/image.mk

index 73fc805bb589da9c9b9a270f3a12dc7524e193dd..fb89ed12222b1b02a5968b7289f133055f7212f7 100644 (file)
@@ -345,6 +345,16 @@ define Build/append-rootfs
        dd if=$(word 2,$^) $(if $(1),bs=$(1) conv=sync) >> $@
 endef
 
+define Build/append-ubi
+       sh $(TOPDIR)/scripts/ubinize-image.sh \
+               $(if $(KERNEL_IN_UBI),--kernel $(word 1,$^)) \
+               $(word 2,$^) \
+               $@.tmp \
+               -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5
+       cat $@.tmp >> $@
+       rm $@.tmp
+endef
+
 define Build/pad-to
        dd if=$@ of=$@.new bs=$(1) conv=sync
        mv $@.new $@