[x86] image: use internal qemu-img for vmdk and vdi images
authorAndy Boyett <agb@openwrt.org>
Mon, 9 Aug 2010 04:22:39 +0000 (04:22 +0000)
committerAndy Boyett <agb@openwrt.org>
Mon, 9 Aug 2010 04:22:39 +0000 (04:22 +0000)
drop host dependencies on qemu-utils and VirtualBox

SVN-Revision: 22553

target/linux/x86/image/Config.in
target/linux/x86/image/Makefile

index b89980c6386b62a9e35c0794db20f989acec272e..308f85cca49847579d8b8d9c96d91adfcbc850a0 100644 (file)
@@ -36,8 +36,6 @@ config X86_VDI_IMAGES
        depends TARGET_x86_generic
        depends TARGET_ROOTFS_EXT2FS
        select PACKAGE_kmod-pcnet32
        depends TARGET_x86_generic
        depends TARGET_ROOTFS_EXT2FS
        select PACKAGE_kmod-pcnet32
-       help
-         Requires VBoxManage installed on the build system.
 
 config X86_VMDK_IMAGES
        bool "Build VMware image files (VMDK)"
 
 config X86_VMDK_IMAGES
        bool "Build VMware image files (VMDK)"
@@ -45,8 +43,6 @@ config X86_VMDK_IMAGES
        depends TARGET_x86_generic
        depends TARGET_ROOTFS_EXT2FS
        select PACKAGE_kmod-e1000
        depends TARGET_x86_generic
        depends TARGET_ROOTFS_EXT2FS
        select PACKAGE_kmod-e1000
-       help
-         Requires qemu-img installed on the build system.
 
 
 config OLPC_BOOTSCRIPT_IMAGES
 
 
 config OLPC_BOOTSCRIPT_IMAGES
index 338c8e0a7492649e1c3e48ecc5f0f2cfe4f5be45..b5297bbff8b1a745d301d9b27959dc9380ce032a 100644 (file)
@@ -143,7 +143,7 @@ ifneq ($(CONFIG_X86_VDI_IMAGES),)
     # left here because the image builder doesnt need these
     ifeq ($(1),ext2)
                rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
     # left here because the image builder doesnt need these
     ifeq ($(1),ext2)
                rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
-               VBoxManage convertfromraw -format VDI \
+               qemu-img convert -f raw -O vdi \
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
                # XXX: VBoxManage insists on setting perms to 0600
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
                # XXX: VBoxManage insists on setting perms to 0600
@@ -191,15 +191,3 @@ define Image/Build
 endef
 
 $(eval $(call BuildImage))
 endef
 
 $(eval $(call BuildImage))
-
-ifneq ($(CONFIG_X86_VDI_IMAGES),)
-  $(eval $(call RequireCommand,VBoxManage, \
-       You need VBoxManage to generate VirtualBox images. \
-  ))
-endif
-
-ifneq ($(CONFIG_X86_VMDK_IMAGES),)
-  $(eval $(call RequireCommand,qemu-img, \
-       You need qemu-img to generate VMware images. \
-  ))
-endif