tools/mkimage: avoid picking up unrelated /usr/include headers with the same name...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 23 Sep 2012 08:49:34 +0000 (08:49 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 23 Sep 2012 08:49:34 +0000 (08:49 +0000)
SVN-Revision: 33519

tools/mkimage/Makefile
tools/mkimage/patches/040-include_order.patch [new file with mode: 0644]

index 373d9bebb8cae886d609f7dd736333584a69b776..149aaa6f12aa3bd22f046f4e9d3a9e5a5c2e3ddd 100644 (file)
@@ -18,6 +18,13 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/host-build.mk
 
+define Host/Prepare
+       $(Host/Prepare/Default)
+       rm -f \
+               $(HOST_BUILD_DIR)/include/errno.h \
+               $(HOST_BUILD_DIR)/include/malloc.h
+endef
+
 define Host/Compile
        rm -f $(HOST_BUILD_DIR)/tools/.depend
        touch $(HOST_BUILD_DIR)/include/config.h
diff --git a/tools/mkimage/patches/040-include_order.patch b/tools/mkimage/patches/040-include_order.patch
new file mode 100644 (file)
index 0000000..5a9d15e
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -159,9 +159,9 @@ NOPEDOBJS := $(addprefix $(obj),$(NOPED_
+ # Use native tools and options
+ # Define __KERNEL_STRICT_NAMES to prevent typedef overlaps
+ #
+-HOSTCPPFLAGS =        -idirafter $(SRCTREE)/include \
++HOSTCPPFLAGS =        -I $(SRCTREE)/include \
+               -idirafter $(OBJTREE)/include2 \
+-              -idirafter $(OBJTREE)/include \
++              -I $(OBJTREE)/include \
+               -I $(SRCTREE)/lib/libfdt \
+               -I $(SRCTREE)/tools \
+               -DCONFIG_SYS_TEXT_BASE=$(CONFIG_SYS_TEXT_BASE) \