procd: make the jail code also work on arm
authorJohn Crispin <john@openwrt.org>
Sat, 23 May 2015 15:26:09 +0000 (15:26 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 23 May 2015 15:26:09 +0000 (15:26 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 45719

package/system/procd/Makefile

index 758f0a4a1a0407953368ace9cb9d8bd3c3fb0246..44a836c4aa07e4ef161ee50b5614354eab783d57 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2015-05-05
+PKG_VERSION:=2015-05-23
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=a6afa72f192f6efe8374d0f0c77fb2a545225a92
+PKG_SOURCE_VERSION:=a771644fd3a3ac055ec0c62fbe434aed0df002fe
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
@@ -77,12 +77,12 @@ config PROCD_ZRAM_TMPFS
 config PROCD_JAIL_SUPPORT
        bool
        default y
-       depends on (mips || mipsel || i386 || x86_64) && PROCD_SECCOMP_SUPPORT
+       depends on (arm || armeb || mips || mipsel || i386 || x86_64) && PROCD_SECCOMP_SUPPORT
 
 config PROCD_SECCOMP_SUPPORT
        bool
        default y
-       depends on (mips || mipsel || i386 || x86_64) && !TARGET_uml && @KERNEL_SECCOMP
+       depends on (arm || armeb || mips || mipsel || i386 || x86_64) && !TARGET_uml && @KERNEL_SECCOMP
 endmenu
 endef