Add ipupdate package
authorFelix Fietkau <nbd@openwrt.org>
Wed, 28 Nov 2007 19:29:42 +0000 (19:29 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 28 Nov 2007 19:29:42 +0000 (19:29 +0000)
Add ipupdate package.

Signed-off-by: Patrick Scharrenberg <pittipatti@web.de>
SVN-Revision: 9620

net/ipupdate/Makefile [new file with mode: 0644]

diff --git a/net/ipupdate/Makefile b/net/ipupdate/Makefile
new file mode 100644 (file)
index 0000000..b48d2a2
--- /dev/null
@@ -0,0 +1,66 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ipupdate
+PKG_VERSION:=1.1.1
+PKG_RELEASE:=0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/ipupdate
+PKG_MD5SUM:=88ad3ac097190055db4ba816b9d26d13
+
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ipupdate
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=IPUpdate-Daemon
+  URL:=http://ipupdate.sourceforge.net
+endef
+
+define Package/ipupdate/description
+  Lightweight remote DNS update-daemon which implements RFC 2136 dynamic updates.
+  Compatible with BIND, Simple DNS, and Microsoft DNS Server.
+endef
+
+
+define Build/Configure
+$(call Build/Configure/Default,, \
+       UNAME_S="Linux" \
+       UNAME_R="$(LINUX_VERSION)" \
+       UNAME_M="$(ARCH)" \
+)
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)/usr
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               COPTS="$(TARGET_CFLAGS)" \
+               PRECOMPILED_FILTER=1 \
+               STAGING_DIR="$(STAGING_DIR)" \
+               DESTDIR="$(PKG_INSTALL_DIR)/usr" \
+               all
+endef
+
+define Package/ipupdate/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ipupdate $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/ipupdate
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dollardns $(1)/etc/ipupdate/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/failover $(1)/etc/ipupdate/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ifip $(1)/etc/ipupdate/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/whatismyip $(1)/etc/ipupdate/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/ipupdate.conf $(1)/etc/
+endef
+
+$(eval $(call BuildPackage,ipupdate))