build: fix git prereq check to not rely on being in a git directory (#21968)
authorFelix Fietkau <nbd@openwrt.org>
Sat, 5 Mar 2016 10:49:59 +0000 (10:49 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 5 Mar 2016 10:49:59 +0000 (10:49 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48926

include/prereq-build.mk

index 23a5b932edf54857fc0458c0006070df97ccf3b6..443b17399de7ec85e1eb84695e4a41a634e811aa 100644 (file)
@@ -155,7 +155,7 @@ $(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
        svn --version | grep Subversion))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
-       git submodule update --help 2>&1 | grep -- --recursive))
+       git submodule --help 2>&1 | grep -q -- --recursive))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))