git package; cleaning up my mess
authorLuka Perkov <luka@openwrt.org>
Mon, 23 May 2011 23:11:03 +0000 (23:11 +0000)
committerLuka Perkov <luka@openwrt.org>
Mon, 23 May 2011 23:11:03 +0000 (23:11 +0000)
SVN-Revision: 26976

net/git/patches/100-fix-cross_compile.patch [deleted file]
net/git/patches/110-convert_builtin.patch

diff --git a/net/git/patches/100-fix-cross_compile.patch b/net/git/patches/100-fix-cross_compile.patch
deleted file mode 100644 (file)
index 7e18054..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -2188,7 +2188,6 @@ endif
-       bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
-       execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
--      ln -s ../../bin/git "$$execdir/git" && \
-       { test "$$bindir/" = "$$execdir/" || \
-         for p in $(filter $(install_bindir_programs),$(ALL_PROGRAMS)); do \
-               $(RM) "$$execdir/$$p" && \
index 279179e5cbbf11c44a07ba659cdcf78ecc89d53a..f2f233a3f17d3440c849b997eccc14b994c0ad58 100644 (file)
  git-http-fetch$X: revision.o http.o http-walker.o http-fetch.o $(GITLIBS)
        $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
                $(LIBS) $(CURL_LIBCURL)
-@@ -2192,23 +2188,22 @@ endif
+@@ -2193,22 +2189,20 @@ endif
        bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
        execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
-+      ln -s ../../bin/git "$$execdir/git" && \
        { test "$$bindir/" = "$$execdir/" || \
 -        for p in git$X $(filter $(install_bindir_programs),$(ALL_PROGRAMS)); do \
 +        for p in $(filter $(install_bindir_programs),$(ALL_PROGRAMS)); do \