Apply patch from #4291 :
authorFlorian Fainelli <florian@openwrt.org>
Thu, 4 Dec 2008 07:56:34 +0000 (07:56 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 4 Dec 2008 07:56:34 +0000 (07:56 +0000)
- fix download URL
- fix bug introduced in [12583], $(INSTALL_DATA) doesn't handle symlinks correctly, it copies the file pointed to by the symlinks, thus the file is copied 3 times, instead of only once with 2 symlinks
- install static library for InstallDev rule, and don't install static library for install rule

SVN-Revision: 13506

libs/libol/Makefile

index b0a2b30851c32e9c6cc0dc5aa159280001bc0657..5d013b901b58b3101d997f5daf7b3cf6b4a473a8 100644 (file)
@@ -13,7 +13,7 @@ PKG_VERSION:=0.3.18
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.balabit.com/downloads/libol/0.3
+PKG_SOURCE_URL:=http://www.balabit.com/downloads/files/libol/0.3
 PKG_MD5SUM:=cbadf4b7ea276dfa85acc38a1cc5ff17
 PKG_FIXUP:=libtool
 
@@ -58,14 +58,14 @@ define Build/InstallDev
                $(1)/usr/include/libol/
 
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/lib/libol.{la,so*} \
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libol.{a,la,so*} \
                $(1)/usr/lib/
 endef
 
 define Package/libol/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/libol.{a,so*} \
                $(1)/usr/lib/
 endef