libs/libpam: update to version 1.1.4
authorAlexandros C. Couloumbis <alex@ozo.com>
Thu, 29 Sep 2011 10:36:49 +0000 (10:36 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Thu, 29 Sep 2011 10:36:49 +0000 (10:36 +0000)
SVN-Revision: 28316

libs/libpam/Makefile
libs/libpam/patches/000-OE-libpam-xtests.patch [new file with mode: 0644]
libs/libpam/patches/001-no_nis.patch
libs/libpam/patches/005-fix_ruserok.patch [new file with mode: 0644]

index 42673e4753ac9031291c517c3e657b1fa3a3c8d8..9c960d9a2450afe4d337bbad19561deabb1fa3d2 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libpam
-PKG_VERSION:=1.1.3
+PKG_VERSION:=1.1.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=Linux-PAM-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@KERNEL/linux/libs/pam/library
-PKG_MD5SUM:=6db7fcb5db6253350e3a4648ceac40e7
+PKG_SOURCE_URL:=http://pkgs.fedoraproject.org/repo/pkgs/pam/Linux-PAM-1.1.4.tar.bz2/e9af5fb27bb22edb55d077e2888b3ebc/
+PKG_MD5SUM:=e9af5fb27bb22edb55d077e2888b3ebc
 PKG_INSTALL:=1
 PKG_FIXUP:=libtool
 
diff --git a/libs/libpam/patches/000-OE-libpam-xtests.patch b/libs/libpam/patches/000-OE-libpam-xtests.patch
new file mode 100644 (file)
index 0000000..aac30ab
--- /dev/null
@@ -0,0 +1,35 @@
+This patch is used to create a new sub package libpam-xtests to do more checks.
+
+Upstream-Status: Pending
+
+Signed-off-by: Kang Kai <kai.kang@windriver.com>
+--- a/xtests/Makefile.am
++++ b/xtests/Makefile.am
+@@ -7,7 +7,7 @@
+ AM_LDFLAGS = -L$(top_builddir)/libpam -lpam \
+       -L$(top_builddir)/libpam_misc -lpam_misc
+-CLEANFILES = *~ $(XTESTS)
++CLEANFILES = *~
+ EXTRA_DIST = run-xtests.sh tst-pam_dispatch1.pamd tst-pam_dispatch2.pamd \
+       tst-pam_dispatch3.pamd tst-pam_dispatch4.pamd \
+@@ -51,3 +51,18 @@
+ xtests: $(XTESTS) run-xtests.sh
+       "$(srcdir)"/run-xtests.sh "$(srcdir)" ${XTESTS} ${NOSRCTESTS}
++
++all: $(XTESTS)
++
++install: install_xtests
++
++install_xtests:
++      $(INSTALL) -d $(DESTDIR)$(pkgdatadir)/xtests
++      for file in $(EXTRA_DIST) ; do \
++              $(INSTALL) $$file $(DESTDIR)$(pkgdatadir)/xtests ; \
++      done
++      for file in $(XTESTS); do \
++              $(INSTALL) .libs/$$file $(DESTDIR)$(pkgdatadir)/xtests ; \
++      done
++
++.PHONY: all install_xtests
index db49bdd6bf4da1b2b423d63995d109667fe0bdf2..27d17a0077da58ce002172cabbdd9a6634d01571 100644 (file)
  #ifdef HAVE_LIBAUDIT
 --- a/modules/pam_unix/pam_unix_passwd.c
 +++ b/modules/pam_unix/pam_unix_passwd.c
-@@ -55,10 +55,10 @@
- #include <sys/time.h>
- #include <sys/stat.h>
- #include <rpc/rpc.h>
--#ifdef HAVE_RPCSVC_YP_PROT_H
-+#ifdef HAVE_RPCSVC_YP_PROT_H && USE_NIS
- #include <rpcsvc/yp_prot.h>
- #endif
--#ifdef HAVE_RPCSVC_YPCLNT_H
-+#ifdef HAVE_RPCSVC_YPCLNT_H && USE_NIS
- #include <rpcsvc/ypclnt.h>
+@@ -74,18 +74,18 @@
+ #include "passverify.h"
+ #include "bigcrypt.h"
+-#if (HAVE_YP_GET_DEFAULT_DOMAIN || HAVE_GETDOMAINNAME) && HAVE_YP_MASTER
++#if (HAVE_YP_GET_DEFAULT_DOMAIN || HAVE_GETDOMAINNAME) && HAVE_YP_MASTER && USE_NIS
+ # define HAVE_NIS
  #endif
  
-@@ -104,7 +104,7 @@ extern int getrpcport(const char *host,
+ #ifdef HAVE_NIS
+ # include <rpc/rpc.h>
+-# if HAVE_RPCSVC_YP_PROT_H
++# if HAVE_RPCSVC_YP_PROT_H && USE_NIS
+ #  include <rpcsvc/yp_prot.h>
+ # endif
+-# if HAVE_RPCSVC_YPCLNT_H
++# if HAVE_RPCSVC_YPCLNT_H && USE_NIS
+ #  include <rpcsvc/ypclnt.h>
+ # endif
  
- static char *getNISserver(pam_handle_t *pamh, unsigned int ctrl)
- {
--#if (defined(HAVE_YP_GET_DEFAULT_DOMAIN) || defined(HAVE_GETDOMAINNAME)) && defined(HAVE_YP_MASTER)
-+#if (defined(HAVE_YP_GET_DEFAULT_DOMAIN) || defined(HAVE_GETDOMAINNAME)) && defined(HAVE_YP_MASTER) && defined(USE_NIS)
-       char *master;
-       char *domainname;
-       int port, err;
 --- a/modules/pam_unix/support.c
 +++ b/modules/pam_unix/support.c
 @@ -19,7 +19,7 @@
diff --git a/libs/libpam/patches/005-fix_ruserok.patch b/libs/libpam/patches/005-fix_ruserok.patch
new file mode 100644 (file)
index 0000000..91a4741
--- /dev/null
@@ -0,0 +1,16 @@
+--- a/modules/pam_rhosts/pam_rhosts.c
++++ b/modules/pam_rhosts/pam_rhosts.c
+@@ -111,11 +111,13 @@ int pam_sm_authenticate (pam_handle_t *p
+       as_root = (lpwd->pw_uid == 0);
+     }
++#if   0
+ #ifdef HAVE_RUSEROK_AF
+     retval = ruserok_af (rhost, as_root, ruser, luser, PF_UNSPEC);
+ #else
+     retval = ruserok (rhost, as_root, ruser, luser);
+ #endif
++#endif
+     if (retval != 0) {
+       if (!opt_silent || opt_debug)
+       pam_syslog(pamh, LOG_WARNING, "denied access to %s@%s as %s",