image: ext4: rename config options as these are only used for ext4 image creation
authorJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:44:10 +0000 (12:44 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:44:10 +0000 (12:44 +0000)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 40926

config/Config-images.in
include/image.mk

index 636a868d593c3446fbd4804f8e51e5373e3486fa..daed0f539053943b9c6c9fe7a1dbb1fd4bf5d194 100644 (file)
@@ -72,14 +72,14 @@ menu "Target Images"
                help
                  Build a ext4 root filesystem
 
-               config TARGET_ROOTFS_MAXINODE
+               config TARGET_EXT4_MAXINODE
                        int "Maximum number of inodes in root filesystem"
                        depends on TARGET_ROOTFS_EXT4FS
                        default 6000
                        help
                          Allows you to change the maximum number of inodes in the root filesystem
 
-               config TARGET_ROOTFS_RESERVED_PCT
+               config TARGET_EXT4_RESERVED_PCT
                        int "Percentage of reserved blocks in root filesystem"
                        depends on TARGET_ROOTFS_EXT4FS
                        default 0
index 2f60ce06d96b08a4fe48777ae8c5dea229df0ab3..a03d4185293057b6824bbef8930cff7c5109c210 100644 (file)
@@ -188,7 +188,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_EXT4FS),)
 
   define Image/mkfs/ext4
 # generate an ext2 fs
-       $(STAGING_DIR_HOST)/bin/genext2fs -U -B $(CONFIG_TARGET_EXT4_BLOCKSIZE) -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4 -m $(CONFIG_TARGET_ROOTFS_RESERVED_PCT) $(MKFS_DEVTABLE_OPT)
+       $(STAGING_DIR_HOST)/bin/genext2fs -U -B $(CONFIG_TARGET_EXT4_BLOCKSIZE) -b $(E2SIZE) -N $(CONFIG_TARGET_EXT4_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4 -m $(CONFIG_TARGET_EXT4_RESERVED_PCT) $(MKFS_DEVTABLE_OPT)
 # convert it to ext4
        $(STAGING_DIR_HOST)/bin/tune2fs $(if $(CONFIG_TARGET_EXT4_JOURNAL),-j) -O extents,uninit_bg,dir_index $(KDIR)/root.ext4
 # fix it up