[packages] asterisk-*: allow headers for multiple versions to co-exist in staging
authorHans Zandbelt <hans.zandbelt@gmail.com>
Wed, 16 Feb 2011 17:29:50 +0000 (17:29 +0000)
committerHans Zandbelt <hans.zandbelt@gmail.com>
Wed, 16 Feb 2011 17:29:50 +0000 (17:29 +0000)
SVN-Revision: 25557

net/asterisk-1.4.x/Makefile
net/asterisk-1.6.x/Makefile
net/asterisk-1.8.x/Makefile
net/asterisk-addons-1.4.x/Makefile
net/asterisk-addons-1.4.x/patches/030-mysql_include.patch [new file with mode: 0644]

index 3591c8567bea34700717048739492129ea4a72af..bac14fe6657c59e41df1729ccc27746db1e76e08 100644 (file)
@@ -7,14 +7,16 @@
 
 include $(TOPDIR)/rules.mk
 
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=asterisk
+PKG_NAME:=asterisk14
 PKG_VERSION:=1.4.25.1
 PKG_RELEASE:=3
 
 PKG_VERSION:=1.4.25.1
 PKG_RELEASE:=3
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=asterisk-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
 PKG_MD5SUM:=ca17be11559eb939ea16b8de98ddeefb
 
 PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
 PKG_MD5SUM:=ca17be11559eb939ea16b8de98ddeefb
 
+PKG_BUILD_DIR=$(BUILD_DIR)/asterisk-$(PKG_VERSION)
+
 PKG_BUILD_DEPENDS:= libopenh323 pwlib
 
 include $(INCLUDE_DIR)/package.mk
 PKG_BUILD_DEPENDS:= libopenh323 pwlib
 
 include $(INCLUDE_DIR)/package.mk
@@ -484,9 +486,9 @@ define Build/Compile
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/asterisk/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/asterisk/*.h $(1)/usr/include/asterisk/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/asterisk.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/include/asterisk-1.4/include/asterisk/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/asterisk/*.h $(1)/usr/include/asterisk-1.4/include/asterisk/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/asterisk.h $(1)/usr/include/asterisk-1.4/include/
 endef
 
 
 endef
 
 
index 0a8baef14740fff3872b9820513ec9f99517a421..356eb83213fc63176b3e9bac21ccfcfeb139bc4f 100644 (file)
@@ -7,14 +7,16 @@
 
 include $(TOPDIR)/rules.mk
 
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=asterisk
+PKG_NAME:=asterisk16
 PKG_VERSION:=1.6.2.14
 PKG_RELEASE:=1
 
 PKG_VERSION:=1.6.2.14
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=asterisk-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
 PKG_MD5SUM:=4f0414c9b2d449222b2fc7096cbaffe7
 
 PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
 PKG_MD5SUM:=4f0414c9b2d449222b2fc7096cbaffe7
 
+PKG_BUILD_DIR=$(BUILD_DIR)/asterisk-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/asterisk16/Default
 include $(INCLUDE_DIR)/package.mk
 
 define Package/asterisk16/Default
index 911d06e1f4fcfc05307ae1adba002bf9491d0a46..b561c0cd79376a498e408620b0735bd51cb18d68 100644 (file)
@@ -7,14 +7,16 @@
 
 include $(TOPDIR)/rules.mk
 
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=asterisk
+PKG_NAME:=asterisk18
 PKG_VERSION:=1.8.2.3
 PKG_RELEASE:=1
 
 PKG_VERSION:=1.8.2.3
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=asterisk-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
 PKG_MD5SUM:=e394b63dd71c07497620dc12883e0b80
 
 PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
 PKG_MD5SUM:=e394b63dd71c07497620dc12883e0b80
 
+PKG_BUILD_DIR=$(BUILD_DIR)/asterisk-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/asterisk18/Default
 include $(INCLUDE_DIR)/package.mk
 
 define Package/asterisk18/Default
@@ -36,7 +38,7 @@ endef
 define Package/asterisk18
 $(call Package/asterisk18/Default)
   TITLE:=Complete open source PBX
 define Package/asterisk18
 $(call Package/asterisk18/Default)
   TITLE:=Complete open source PBX
-  DEPENDS:= +libopenssl +libncurses +libpopt +libpthread +zlib @!TARGET_avr32 @!PACKAGE_asterisk14
+  DEPENDS:= +libopenssl +libncurses +libpopt +libpthread +zlib @!TARGET_avr32
 endef
 
 define Package/asterisk18/description
 endef
 
 define Package/asterisk18/description
@@ -114,18 +116,6 @@ $(call Package/asterisk18/Default/description)
  Asterisk.
 endef
 
  Asterisk.
 endef
 
-define Package/asterisk18-res-rtp-asterisk
-$(call Package/asterisk18/Default)
-  TITLE:=RTP Support
-  DEPENDS:= +asterisk18
-endef
-
-define Package/asterisk18-res-rtp-asterisk/description
-$(call Package/asterisk18/Default/description)
- This package provides RTP support to Asterisk.
- It is needed by chan_sip.
-endef
-
 define Package/asterisk18-chan-gtalk
 $(call Package/asterisk18/Default)
   TITLE:=GTalk support
 define Package/asterisk18-chan-gtalk
 $(call Package/asterisk18/Default)
   TITLE:=GTalk support
@@ -235,9 +225,9 @@ define Build/Compile
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/asterisk/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/asterisk/*.h $(1)/usr/include/asterisk/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/asterisk.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/include/asterisk-1.8/include/asterisk/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/asterisk/*.h $(1)/usr/include/asterisk-1.8/include/asterisk/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/asterisk.h $(1)/usr/include/asterisk-1.8/include/
 endef
 
 define Package/asterisk18/conffiles
 endef
 
 define Package/asterisk18/conffiles
@@ -264,7 +254,7 @@ define Package/asterisk18/install
        done
        $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
        for f in app_dial app_echo app_playback app_macro \
        done
        $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
        for f in app_dial app_echo app_playback app_macro \
-               chan_sip \
+               chan_sip res_rtp \
                codec_ulaw codec_gsm \
                format_gsm format_pcm format_wav format_wav_gsm \
                pbx_config \
                codec_ulaw codec_gsm \
                format_gsm format_pcm format_wav format_wav_gsm \
                pbx_config \
@@ -355,16 +345,6 @@ define Package/asterisk18-res-musiconhold/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/res_musiconhold.so $(1)/usr/lib/asterisk/modules/
 endef
 
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/res_musiconhold.so $(1)/usr/lib/asterisk/modules/
 endef
 
-define Package/asterisk18-res-rtp-asterisk/install
-       $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/res_rtp*.so $(1)/usr/lib/asterisk/modules/
-endef
-
-define Package/asterisk18-res-rtp-asterisk/install 
-       $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/res_rtp*.so $(1)/usr/lib/asterisk/modules/ 
-endef 
-
 define Package/asterisk18-chan-gtalk/conffiles
 /etc/asterisk/gtalk.conf
 /etc/asterisk/jabber.conf
 define Package/asterisk18-chan-gtalk/conffiles
 /etc/asterisk/gtalk.conf
 /etc/asterisk/jabber.conf
@@ -413,7 +393,6 @@ $(eval $(call BuildPackage,asterisk18-sounds))
 $(eval $(call BuildPackage,asterisk18-chan-iax2))
 $(eval $(call BuildPackage,asterisk18-cdr))
 $(eval $(call BuildPackage,asterisk18-res-musiconhold))
 $(eval $(call BuildPackage,asterisk18-chan-iax2))
 $(eval $(call BuildPackage,asterisk18-cdr))
 $(eval $(call BuildPackage,asterisk18-res-musiconhold))
-$(eval $(call BuildPackage,asterisk18-res-rtp-asterisk)) 
 $(eval $(call BuildPackage,asterisk18-chan-gtalk))
 $(eval $(call BuildPackage,asterisk18-curl))
 $(eval $(call Buildasterisk18ModuleTemplate,app_authenticate,Authenticate,support for executing arbitrary authenticate commands))
 $(eval $(call BuildPackage,asterisk18-chan-gtalk))
 $(eval $(call BuildPackage,asterisk18-curl))
 $(eval $(call Buildasterisk18ModuleTemplate,app_authenticate,Authenticate,support for executing arbitrary authenticate commands))
index 7fe91b5673a567ce7bc615e36f485338688c4152..36c48ca778f0f6af1874d568f8807f24c6bb33df 100644 (file)
@@ -91,14 +91,11 @@ ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk14-mysql),)
 endif
 
 CONFIGURE_ARGS += \
 endif
 
 CONFIGURE_ARGS += \
-       --with-asterisk="$(STAGING_DIR)/usr" \
+       --with-asterisk="$(STAGING_DIR)/usr/include/asterisk-1.4" \
        --with-bluetooth="$(STAGING_DIR)/usr" \
        --with-ncurses="$(STAGING_DIR)/usr" \
        --with-mysqlclient="$(STAGING_DIR)/usr" \
        --with-bluetooth="$(STAGING_DIR)/usr" \
        --with-ncurses="$(STAGING_DIR)/usr" \
        --with-mysqlclient="$(STAGING_DIR)/usr" \
-
-CONFIGURE_VARS += \
-       ac_cv_file__usr_include_asterisk_channel_h="yes" \
-
+       
 define Build/Configure
        ( cd $(PKG_BUILD_DIR); ./bootstrap.sh )
        $(call Build/Configure/Default,,,)
 define Build/Configure
        ( cd $(PKG_BUILD_DIR); ./bootstrap.sh )
        $(call Build/Configure/Default,,,)
diff --git a/net/asterisk-addons-1.4.x/patches/030-mysql_include.patch b/net/asterisk-addons-1.4.x/patches/030-mysql_include.patch
new file mode 100644 (file)
index 0000000..2782d04
--- /dev/null
@@ -0,0 +1,16 @@
+--- asterisk-addons-1.4.8/configure.ac.org     2011-02-16 15:32:41.000000000 +0100
++++ asterisk-addons-1.4.8/configure.ac 2011-02-16 15:36:05.000000000 +0100
+@@ -191,11 +191,13 @@
+ fi
+ if test x"${MYSQL_CONFIG}" != xNo; then
+    MYSQLCLIENT_libs=`mysql_config --libs`
++   MYSQLCLIENT_include=`mysql_config --include`
+    
+    AC_CHECK_LIB([mysqlclient], [mysql_init], [], [], ${MYSQLCLIENT_libs})
+    if test "${ac_cv_lib_mysqlclient_mysql_init}" = "yes"; then
+       MYSQLCLIENT_LIB="${MYSQLCLIENT_libs}"
++      MYSQLCLIENT_INCLUDE="${MYSQLCLIENT_include}/.."
+       PBX_MYSQLCLIENT=1
+    elif test ! -z "${MYSQLCLIENT_MANDATORY}";
+    then