netifd: ensure that a bridge gets created before hostapd needs it, hostapd must not...
authorFelix Fietkau <nbd@openwrt.org>
Fri, 4 Nov 2011 01:05:12 +0000 (01:05 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 4 Nov 2011 01:05:12 +0000 (01:05 +0000)
SVN-Revision: 28745

package/base-files-network/files/lib/network/config.sh
package/base-files/files/sbin/wifi
package/netifd/Makefile
package/netifd/files/lib/network/config.sh

index 29d021af92c1ce92a5a891ec421ac25e0bfbd001..74810e47d0aa3756c8739a7e4bf948e084f18edb 100755 (executable)
@@ -145,6 +145,10 @@ sort_list() {
        ) | sort -u
 }
 
+prepare_interface_bridge() {
+       return 0
+}
+
 # Create the interface, if necessary.
 # Return status 0 indicates that the setup_interface() call should continue
 # Return status 1 means that everything is set up already.
index e2dd0a32d560fddc552eee6be66786aa9ed099ac..2e66bfcbe8d113accdf911c2dd0423d2bed95be5 100755 (executable)
@@ -40,6 +40,7 @@ bridge_interface() {(
 
        config_get iftype "$cfg" type
        [ "$iftype" = bridge ] && config_get "$cfg" ifname
+       prepare_interface_bridge "$cfg"
 )}
 
 prepare_key_wep() {
index 465acd4122d06e224466c7d744b2f42db175eb47..98b4a4044f082c8d9b2b8b0e2cba4cc2bebe89a8 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_VERSION:=2011-11-03
+PKG_VERSION:=2011-11-04
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/netifd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=5c0c0bb557b17c581d4f238c52b0b44ada34a608
+PKG_SOURCE_VERSION:=b6d7a8bc9822667cb851bec465c3ad7cd6714e90
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 # PKG_MIRROR_MD5SUM:=
 # CMAKE_INSTALL:=1
index 778c964e7b28fc5c85b969cc2c23b997dbd19eca..4ce362eb199917b1a940abc5e7be9ddafbaf7508 100755 (executable)
@@ -40,6 +40,13 @@ scan_interfaces() {
        config_foreach fixup_interface interface
 }
 
+prepare_interface_bridge() {
+       local config="$1"
+
+       [ -n "$config" ] || return 0
+       ubus call network.interface."$config" prepare
+}
+
 setup_interface() {
        local iface="$1"
        local config="$2"