atftp:
authorOliver Ertl <oliver@ertl-net.net>
Thu, 2 Aug 2007 21:13:22 +0000 (21:13 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Thu, 2 Aug 2007 21:13:22 +0000 (21:13 +0000)
 * Cleanup Makefile
 * Fix download URL
 * Refresh patches

SVN-Revision: 8321

net/atftp/Makefile
net/atftp/patches/100-mconfig.patch
net/atftp/patches/110-services.patch
net/atftp/patches/120-retry_setting.patch

index 0ca8a0df08209595f1796d853c1d9d0deef8f670..54e8a0954d20b08d74084be604f3a38f617ff492 100644 (file)
@@ -13,12 +13,8 @@ PKG_VERSION:=0.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.mamalinux.com/pub/atftp/
+PKG_SOURCE_URL:=http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/distfiles/
 PKG_MD5SUM:=3b27365772d918050b2251d98a9c7c82
-PKG_CAT:=zcat
-TAR_OPTIONS += || true
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 PKG_BUILD_DEPENDS:=libncurses libpcre libreadline
 
@@ -28,7 +24,6 @@ define Package/atftp/Default
   SECTION:=net
   CATEGORY:=Network
   TITLE:=TFTP
-  URL:=ftp://ftp.mamalinux.com/pub/atftp/
 endef
 
 define Package/atftp
@@ -54,18 +49,13 @@ if [ $$? -ne 0 ]; then
 fi
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-libwrap \
-       )
-endef
+CONFIGURE_ARGS += \
+       --disable-libwrap 
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -Wall -D_REENTRANT" \
-               all
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) \
+       -Wall -D_REENTRANT" \
+       all
 
 define Package/atftp/install
        $(INSTALL_DIR) $(1)/usr/sbin
index 552204ee230a3d51fde20a7b8970c5d0e1180abc..01c1e36508341cfc044c8b583f5f804403a9a5e5 100644 (file)
@@ -1,6 +1,7 @@
-diff -Nur netkit-tftp-0.17/MCONFIG netkit-tftp-0.17.patched/MCONFIG
---- netkit-tftp-0.17/MCONFIG   1970-01-01 01:00:00.000000000 +0100
-+++ netkit-tftp-0.17.patched/MCONFIG   2005-06-19 21:16:52.422687029 +0200
+Index: atftp-0.7/MCONFIG
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ atftp-0.7/MCONFIG  2007-08-02 23:04:23.000000000 +0200
 @@ -0,0 +1,16 @@
 +# Generated by configure (confgen version 2) on Sun Jun 19 21:13:24 CEST 2005
 +#
index 0a5972fcf456d236a27adaee76500bca99f8a50c..ab3e1fb87b40bc1f265a4ac5ef4d59c988d91bf3 100644 (file)
@@ -1,6 +1,7 @@
-diff -urN atftp.old/tftp.c atftp.dev/tftp.c
---- atftp.old/tftp.c   2004-03-16 00:55:56.000000000 +0100
-+++ atftp.dev/tftp.c   2006-03-22 10:18:54.000000000 +0100
+Index: atftp-0.7/tftp.c
+===================================================================
+--- atftp-0.7.orig/tftp.c      2007-08-02 23:04:23.000000000 +0200
++++ atftp-0.7/tftp.c   2007-08-02 23:04:23.000000000 +0200
 @@ -409,7 +409,7 @@
  int set_peer(int argc, char **argv)
  {
@@ -55,9 +56,10 @@ diff -urN atftp.old/tftp.c atftp.dev/tftp.c
  
       data.connected = 1;
       return OK;
-diff -urN atftp.old/tftpd.c atftp.dev/tftpd.c
---- atftp.old/tftpd.c  2004-02-27 03:05:26.000000000 +0100
-+++ atftp.dev/tftpd.c  2006-03-22 10:23:20.000000000 +0100
+Index: atftp-0.7/tftpd.c
+===================================================================
+--- atftp-0.7.orig/tftpd.c     2007-08-02 23:04:23.000000000 +0200
++++ atftp-0.7/tftpd.c  2007-08-02 23:04:23.000000000 +0200
 @@ -230,14 +230,8 @@
  
            /* find the port */
index b77ed30d23e658212de9c4f35ced6eaeb19e897f..548090ce28e3122ab5b82c287882702888eee44f 100644 (file)
@@ -1,6 +1,7 @@
-diff -urN atftp.old/tftp.c atftp.dev/tftp.c
---- atftp.old/tftp.c   2006-03-25 16:41:49.000000000 +0100
-+++ atftp.dev/tftp.c   2006-03-25 18:10:04.000000000 +0100
+Index: atftp-0.7/tftp.c
+===================================================================
+--- atftp-0.7.orig/tftp.c      2007-08-02 23:04:23.000000000 +0200
++++ atftp-0.7/tftp.c   2007-08-02 23:04:23.000000000 +0200
 @@ -967,6 +967,7 @@
            { "tftp-timeout", 1, NULL, 'T'},
            { "mode", 1, NULL, 'M'},
@@ -27,9 +28,10 @@ diff -urN atftp.old/tftp.c atftp.dev/tftp.c
            case 'g':
                 interactive = 0;
                 if ((action == PUT) || (action == MGET))
-diff -urN atftp.old/tftp_def.c atftp.dev/tftp_def.c
---- atftp.old/tftp_def.c       2004-02-13 04:16:09.000000000 +0100
-+++ atftp.dev/tftp_def.c       2006-03-25 18:10:04.000000000 +0100
+Index: atftp-0.7/tftp_def.c
+===================================================================
+--- atftp-0.7.orig/tftp_def.c  2007-08-02 23:04:23.000000000 +0200
++++ atftp-0.7/tftp_def.c       2007-08-02 23:04:23.000000000 +0200
 @@ -37,6 +37,7 @@
       { "timeout", "5", 0, 1 },  /* 2348, 2349, 2090.  */
       { "blksize", "512", 0, 1 }, /* This is the default option */
@@ -38,9 +40,10 @@ diff -urN atftp.old/tftp_def.c atftp.dev/tftp_def.c
       { "", "", 0, 0}
  };
  
-diff -urN atftp.old/tftp_def.h atftp.dev/tftp_def.h
---- atftp.old/tftp_def.h       2004-02-13 04:16:09.000000000 +0100
-+++ atftp.dev/tftp_def.h       2006-03-25 17:19:15.000000000 +0100
+Index: atftp-0.7/tftp_def.h
+===================================================================
+--- atftp-0.7.orig/tftp_def.h  2007-08-02 23:04:23.000000000 +0200
++++ atftp-0.7/tftp_def.h       2007-08-02 23:04:23.000000000 +0200
 @@ -40,7 +40,8 @@
  #define OPT_TIMEOUT   3
  #define OPT_BLKSIZE   4
@@ -51,9 +54,10 @@ diff -urN atftp.old/tftp_def.h atftp.dev/tftp_def.h
  
  #define OPT_SIZE     12
  #define VAL_SIZE     MAXLEN
-diff -urN atftp.old/tftp_file.c atftp.dev/tftp_file.c
---- atftp.old/tftp_file.c      2004-02-13 04:16:09.000000000 +0100
-+++ atftp.dev/tftp_file.c      2006-03-25 18:10:04.000000000 +0100
+Index: atftp-0.7/tftp_file.c
+===================================================================
+--- atftp-0.7.orig/tftp_file.c 2007-08-02 23:04:23.000000000 +0200
++++ atftp-0.7/tftp_file.c      2007-08-02 23:04:23.000000000 +0200
 @@ -123,6 +123,7 @@
       struct tftphdr *tftphdr = (struct tftphdr *)data->data_buffer;
       FILE *fp = NULL;           /* the local file pointer */