Add mips kernel entry patch
authorFlorian Fainelli <florian@openwrt.org>
Tue, 2 May 2006 10:28:13 +0000 (10:28 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 2 May 2006 10:28:13 +0000 (10:28 +0000)
Fix image creation

SVN-Revision: 3723

openwrt/target/linux/au1000-2.6/Makefile
openwrt/target/linux/au1000-2.6/patches/009-boot.patch [new file with mode: 0644]
openwrt/target/linux/image/au1000/Makefile

index 35ab1034cff179d8f45f3acfaa8dae8a3edd74eb..4b596f603a9beb9d3c1b47930e2dea5b4bc0f962 100644 (file)
@@ -17,10 +17,10 @@ $(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
        @$(CP) config $(LINUX_DIR)/.config
        touch $@
 
-$(LINUX_BUILD_DIR)/zImage: $(LINUX_DIR)/vmlinux
+$(LINUX_BUILD_DIR)/zImage.flash.srec: $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec
        $(MAKE) -C $(LINUX_DIR) V=1 CROSS_COMPILE=$(TARGET_CROSS) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) zImage.flash $(MAKE_TRACE)
-       $(CP) $(LINUX_DIR)/vmlinux $@
-       echo "toto"
+       $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
+       $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
        touch $@
 
 compile: $(LINUX_DIR)/vmlinux
diff --git a/openwrt/target/linux/au1000-2.6/patches/009-boot.patch b/openwrt/target/linux/au1000-2.6/patches/009-boot.patch
new file mode 100644 (file)
index 0000000..611c70d
--- /dev/null
@@ -0,0 +1,15 @@
+diff -Nur linux-cvs/arch/mips/kernel/head.S linux-aruba/arch/mips/kernel/head.S
+--- linux-cvs/arch/mips/kernel/head.S  2004-12-23 00:21:39.000000000 -0800
++++ linux-aruba/arch/mips/kernel/head.S        2005-10-20 09:16:08.000000000 -0700
+@@ -122,6 +122,10 @@
+ #endif
+       .endm
++
++      j kernel_entry
++      nop
++
+       /*
+        * Reserved space for exception handlers.
+        * Necessary for machines which link their kernels at KSEG0.
+
index fd805eef7247429f9182b02d86c7d3c93c170ad8..414873189fc44236cc9c13bd7fd04356e7d39cd5 100644 (file)
@@ -1,6 +1,6 @@
 include $(TOPDIR)/rules.mk
 
-LOADADDR = 0x8008c8f4          # RAM start + 16M 
+LOADADDR = 0x8108c8f4          # RAM start + 16M 
 KERNEL_ENTRY = 0x80100000
 RAMSIZE = 0x04000000           # 1MB
 
@@ -31,25 +31,12 @@ endif
 ifeq ($(KERNEL),2.6)
 FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
 
-$(KDIR)/vmlinux.srec: $(KDIR)/vmlinux
-       $(TARGET_CROSS)objcopy -O srec $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.srec
-
-ifeq ($(FS),jffs2-4MB)
-
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(KDIR)/root.$(FS) $(KDIR)/vmlinux.srec
-       $(TARGET_CROSS)objcopy -O srec -I binary --adjust-vma 0xbe000000 $(KDIR)/root.$(FS) $(KDIR)/root.srec
-       grep -v S7 $(KDIR)/root.srec > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
-       grep -v S0 $(KDIR)/vmlinux.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
-
-install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin
-endif
-
 ifeq ($(FS),jffs2-8MB)
 
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(KDIR)/root.$(FS) $(KDIR)/vmlinux.srec
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(KDIR)/root.$(FS)
        $(TARGET_CROSS)objcopy -O srec -I binary --adjust-vma 0xbe000000 $(KDIR)/root.$(FS) $(KDIR)/root.srec
        grep -v S7 $(KDIR)/root.srec > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
-       grep -v S0 $(KDIR)/vmlinux.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
+       grep -v S0 $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
 
 install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin
 endif
@@ -64,16 +51,17 @@ install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
 endif
 
 ifeq ($(FS),squashfs)
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(KDIR)/root.$(FS) $(KDIR)/vmlinux.srec
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(KDIR)/root.$(FS)
        $(TARGET_CROSS)objcopy -O srec -I binary --adjust-vma 0xbe000000 $(KDIR)/root.$(FS) $(KDIR)/root.srec
        grep -v S7 $(KDIR)/root.srec > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
+       grep -v S0 $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
 
 endif
 
 install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin
 endif
 
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/vmlinux
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/zImage.flash
        $(CP) $^ $@
 
 ifeq ($(IB),)