[packages] paris-traceroute libc++ fix
authorJohn Crispin <john@openwrt.org>
Fri, 3 Aug 2012 21:35:45 +0000 (21:35 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 3 Aug 2012 21:35:45 +0000 (21:35 +0000)
SVN-Revision: 32969

net/paris-traceroute/Makefile

index df8c282ffbe8fca7c5ff7d1d847214e8e759b7f4..01d90add7a6d47fc2b688287a88a404f233168d5 100644 (file)
@@ -19,6 +19,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-current
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
+include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/paris-traceroute
@@ -26,7 +27,7 @@ define Package/paris-traceroute
   CATEGORY:=Network
   TITLE:=Paris Traceroute
   URL:=http://www.paris-traceroute.net/
-  DEPENDS:=+libpthread +uclibcxx
+  DEPENDS:=+libpthread $(CXX_DEPENDS)
 endef
 
 define Package/paris-traceroute/description
@@ -35,7 +36,6 @@ define Package/paris-traceroute/description
   initial implementation of traceroute.
 endef
 
-TARGET_CXX = $(STAGING_DIR)/host/bin/g++-uc
 TARGET_LDFLAGS += -lm
 
 define Package/paris-traceroute/install