removed lots of unneeded fluxbox files and added our own menu
authorJohn Crispin <john@openwrt.org>
Thu, 20 Sep 2007 19:46:44 +0000 (19:46 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 20 Sep 2007 19:46:44 +0000 (19:46 +0000)
SVN-Revision: 8888

XOrg/app/fluxbox/Makefile
XOrg/app/fluxbox/files/menu [new file with mode: 0644]

index b86548286c345df725b17f4a0cb0e758ed94c1e4..a01792cbc308550d5a4d8c47a1fb39a4af68d971 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 CONFIGURE_VARS+=LIBS="-nodefaultlibs -luClibc++ -Wl,-Bstatic,-lstdc++,-Bdynamic -lm" \
                CXXLD="$(TARGET_CC)" 
 
-CONFIGURE_ARGS+=--disable-static --disable-xmb
+CONFIGURE_ARGS+=--disable-xmb
 
 define Package/fluxbox
   SECTION:=xorg-wm
@@ -49,9 +49,12 @@ define Build/Compile
 endef
 
 define Package/fluxbox/install
-       $(INSTALL_DIR) $(1)/usr/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ $(1)/usr/
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/ $(1)/usr/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/share/fluxbox/styles/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/{fluxbox,fbsetbg} $(1)/usr/
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/fluxbox/{init,keys} $(1)/usr/share/fluxbox/
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/fluxbox/styles/BlueFlux/ $(1)/usr/share/fluxbox/styles
+       $(CP) files/menu $(1)/usr/share/fluxbox/
 endef
 
 $(eval $(call BuildPackage,fluxbox))
diff --git a/XOrg/app/fluxbox/files/menu b/XOrg/app/fluxbox/files/menu
new file mode 100644 (file)
index 0000000..3357552
--- /dev/null
@@ -0,0 +1,31 @@
+[begin] (Fluxbox-OpenWrt)
+      [exec] (xterm) {xterm}
+      [exec]   (vi) {xterm -e vi}
+      [exec]   (xmms) {xmms}
+      [exec]   (alsamixer) {xterm -e alsamixer}
+      [exec]   (vlc) {vlc}
+      [exec]   (xclock) {xclock}
+      [exec]   (xmag) {xmag}
+      [exec]   (xclock) {xclock}
+      [exec]   (xcalc) {xcalc}
+      [exec]   (xpdf) {xpdf}
+      [exec]   (top) {xterm -e top}
+[submenu] (fluxbox menu)
+      [config] (Configure)
+[submenu] (System Styles) {Choose a style...}
+      [stylesdir] (/usr/share/fluxbox/styles)
+[end]
+      [workspaces] (Workspace List)
+[submenu] (Tools)
+      [exec]   (fluxconf) {fluxconf}
+      [exec]   (fluxkeys) {fluxkeys}
+      [exec]   (fluxmenu) {fluxmenu}
+[end]
+      [commanddialog] (Fluxbox Command)
+      [reconfig] (Reload config)
+      [restart] (Restart)
+      [exec] (About) {(fluxbox -v; fluxbox -info | sed 1d) 2> /dev/null | xmessage -file - -center}
+      [separator]
+      [exit] (Exit)
+[end]
+[end]