brcm63xx: use dtb board detection for NB6
authorJonas Gorski <jogo@openwrt.org>
Mon, 11 Aug 2014 11:37:17 +0000 (11:37 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 11 Aug 2014 11:37:17 +0000 (11:37 +0000)
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42127

25 files changed:
target/linux/brcm63xx/dts/nb6-ser-r0.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch
target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch
target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch

diff --git a/target/linux/brcm63xx/dts/nb6-ser-r0.dts b/target/linux/brcm63xx/dts/nb6-ser-r0.dts
new file mode 100644 (file)
index 0000000..ea3b1fa
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6362.dtsi"
+
+/ {
+       model = "SFR neufbox 6 (Sercomm)";
+       compatible = "sfr,nb6-ser-r0", "brcm,bcm6362";
+};
index 9ee97d15a6acda9e16e2910d7efe7cab6b30c451..9f1389680e4bba6d85b4497fc9176c853315cfc6 100755 (executable)
@@ -279,9 +279,6 @@ define Image/Build
        # Zyxel P870HW-51a v2
        $(call Image/Build/ZyXEL,$(1),96368VVW,P870HW-51a_v2,6368,P870HW-51a_v2,ZyXEL,--signature "ZyXEL_0001")
 
-       # Neufbox6
-       $(call Image/Build/CFE,$(1),NB6-SER-r0,6362,NEUFBOX6,OpenWRT-$(REVISION))
-
        # Sagem F@ST2504n
        $(call Image/Build/CFE,$(1),F@ST2504n,6362,F@ST2504n,OpenWRT-$(REVISION))
 
@@ -391,4 +388,7 @@ $(eval $(call HW556ImageDTB,hg556a-a,HW556-A))
 $(eval $(call HW556ImageDTB,hg556a-b,HW556-B))
 $(eval $(call HW556ImageDTB,hg556a-c,HW556-C))
 
+# SFR neufbox 6
+$(call $(call CfeImageDTB,nb6-ser-r0,NB6-SER-r0,6362,NEUFBOX6,OpenWRT-$(REVISION)))
+
 $(eval $(call BuildImage))
index 3474b34c60d45687bdeb0b7622ca1f701946b49a..9754c00fdf140a7146f2f0ce398936a77918d5c6 100644 (file)
@@ -17,7 +17,7 @@
  
  #define CT6373_PID_OFFSET             0xff80
  #define CT6373_74X164_GPIO_BASE       64
-@@ -2717,6 +2720,104 @@ static struct board_info __initdata boar
+@@ -2717,6 +2720,105 @@ static struct board_info __initdata boar
  };
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
@@ -56,6 +56,7 @@
 +
 +static struct board_info __initdata board_nb6 = {
 +      .name                           = "NB6",
++      .of_board_id                    = "sfr,nb6-ser-r0",
 +      .expected_cpu_id                = 0x6362,
 +
 +      .has_uart0                      = 1,
  /*
   * known 6368 boards
   */
-@@ -2923,6 +3024,10 @@ static const struct board_info __initcon
+@@ -2923,6 +3025,10 @@ static const struct board_info __initcon
        &board_DVAG3810BN,
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
-@@ -2944,6 +3049,11 @@ static void __init boardid_fixup(u8 *boo
-               }
-       }
-+      if (BCMCPU_IS_6362() && (!strncmp(board_name, "NB6-", sizeof("NB6-") - 1))) {
-+              board_name[sizeof("NB6") - 1] = '\0';
-+              return ;
-+      }
-+
-       /* check if bcm_tag is at 64k offset */
-       if (strncmp(board_name, tag->board_id, BOARDID_LEN) != 0) {
-               /* else try 128k */
index 8b174a257ca443656748e9c5ea0dc3b247073447..dbbe383beec286b34533895de256882c19914557 100644 (file)
@@ -58,7 +58,7 @@
  static struct board_info __initdata board_rta1025w_16 = {
        .name                           = "RTA1025W_16",
        .of_board_id                    = "dynalink,rta1025w",
-@@ -2992,6 +3043,7 @@ static const struct board_info __initcon
+@@ -2993,6 +3044,7 @@ static const struct board_info __initcon
        &board_96348gw_10,
        &board_96348gw_11,
        &board_FAST2404,
index 7da2434747c4a4fbcc39d3bd3362e8a41435386a..318c2bc9b46945d1998b13a465011b532aa397ad 100644 (file)
  static struct board_info __initdata board_dsl_274xb_f1 = {
        .name                           = "AW4339U",
        .expected_cpu_id                = 0x6328,
-@@ -3024,6 +3151,7 @@ static const struct board_info __initcon
+@@ -3025,6 +3152,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index 5bb6995cb75529dbe5930d58bb58d9a5fc955aff..14b5791f2707cd84ea2f0e3b1f964bca851fb82d 100644 (file)
  static struct board_info __initdata board_963281TAN = {
        .name                           = "963281TAN",
        .expected_cpu_id                = 0x6328,
-@@ -3150,6 +3259,7 @@ static const struct board_info __initcon
+@@ -3151,6 +3260,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 5ef455dd331d548ebdc50965091cdb70f60da34c..a095d371e761e22f09832e7cf3c60b9692c63d3b 100644 (file)
@@ -92,7 +92,7 @@
  static struct sprom_fixup __initdata ar5387un_fixups[] = {
        { .offset = 2, .value = 0x05bb },
        { .offset = 65, .value = 0x1204 },
-@@ -3259,6 +3344,7 @@ static const struct board_info __initcon
+@@ -3260,6 +3345,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index a8f59423454006e40693e63b7abb945f7c23e86f..a1c13366c20cac09e7709e199987be470ce3c94e 100644 (file)
@@ -56,7 +56,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3358,6 +3407,7 @@ static const struct board_info __initcon
+@@ -3359,6 +3408,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
index 4f1e90cec60782497926425094b6de556b5d8954..5f169560337e91d275bae261d59ee2f9a52cf12f 100644 (file)
   /* T-Home Speedport W 303V Typ B */
  static struct board_info __initdata board_spw303v = {
        .name                   = "96358-502V",
-@@ -3446,6 +3936,10 @@ static const struct board_info __initcon
+@@ -3447,6 +3937,10 @@ static const struct board_info __initcon
        &board_nb4_fxc_r2,
        &board_ct6373_1,
        &board_HW553,
index 5a60a6ab58597c5c7447cad3ab277a2d00a71ac8..dd7ac06645bcc112e7b5d58bfc66c0fd2be1b3bf 100644 (file)
@@ -61,7 +61,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3898,6 +3952,7 @@ static const struct board_info __initcon
+@@ -3899,6 +3953,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
        &board_rta770bw,
index 98de734d8f10ae125cbfa4883ba223a8459a67da..928bcb32ac9cdec752ebabeb35dbf73bf046d93c 100644 (file)
@@ -135,7 +135,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -3942,6 +4058,7 @@ static const struct board_info __initcon
+@@ -3943,6 +4059,7 @@ static const struct board_info __initcon
        &board_963281TAN,
        &board_A4001N1,
        &board_dsl_274xb_f1,
index 172cc6faae9edbe0ee9a41bf8778628d834498c0..8328aeb2405f8f24ccf3cb0c69cd2e63c0aa3542 100644 (file)
@@ -6,7 +6,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3897,6 +3897,96 @@ static struct board_info __initdata boar
+@@ -3898,6 +3898,96 @@ static struct board_info __initdata boar
        .devs = nb6_devices,
        .num_devs = ARRAY_SIZE(nb6_devices),
  };
@@ -103,7 +103,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif /* CONFIG_BCM63XX_CPU_6362 */
  
  /*
-@@ -4118,6 +4208,7 @@ static const struct board_info __initcon
+@@ -4119,6 +4209,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6362
        &board_nb6,
index 2fe1ceb96bd2f5319a1e6bd76ccb99ae21c83c3f..85e2e83c5f394623cbfb3d2325c95e8908bd962f 100644 (file)
@@ -94,7 +94,7 @@
   * known 6328 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_6328
-@@ -4372,6 +4459,9 @@ static const struct board_info __initcon
+@@ -4373,6 +4460,9 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_3368
        &board_cvg834g,
  #endif
index 94823f28feff6fc82609b38ae21e66520a1ea82e..db6138d291c58eb89cb5c32fda28da33a869bb12 100644 (file)
@@ -95,7 +95,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -4461,6 +4549,7 @@ static const struct board_info __initcon
+@@ -4462,6 +4550,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
index e7a2f82bb18fa54659011e447b26e2d59521c59a..1a9c6bcdaf1e3307e2561c5d30d8647c8a1579db 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4541,6 +4541,75 @@ static struct board_info __initdata boar
+@@ -4542,6 +4542,75 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
@@ -76,7 +76,7 @@
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -4625,6 +4694,9 @@ static const struct board_info __initcon
+@@ -4626,6 +4695,9 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
index c52212a2f1874c48d8f9200657427e611a466263..0e326180fb2350a02c1a5f084815d592b72d4301 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  
  /* BT Voyager 2110 */
  static struct board_info __initdata board_V2110 = {
-@@ -4661,6 +4707,7 @@ static const struct board_info __initcon
+@@ -4662,6 +4708,7 @@ static const struct board_info __initcon
        &board_96348A_122,
        &board_CPVA502plus,
        &board_96348W3,
index 272ee5acd596ddc455bcd0efaad8824372c7f803..c18d3549130d9bcbbcf6a2353eb7dc002bbc3244 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4653,6 +4653,108 @@ static struct board_info __initdata boar
+@@ -4654,6 +4654,108 @@ static struct board_info __initdata boar
                },
        },
  };
  #endif /* CONFIG_BCM63XX_CPU_63268 */
  
  /*
-@@ -4743,6 +4845,7 @@ static const struct board_info __initcon
+@@ -4744,6 +4846,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
index 65c8add37f8258a8f7ce5485ee36858178b4c130..2b750f4de0573caf3a78f54147aa61ed9ac5eaaf 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4590,6 +4590,131 @@ static struct board_info __initdata boar
+@@ -4591,6 +4591,131 @@ static struct board_info __initdata boar
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -4844,6 +4969,7 @@ static const struct board_info __initcon
+@@ -4845,6 +4970,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 87c00698ee292fa0ab5bf3902793f4af5956705b..77c0b06cc875bb24c16ce9e6a94ea022f399f41d 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -4584,6 +4585,117 @@ static struct board_info __initdata boar
+@@ -4585,6 +4586,117 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -4967,6 +5079,7 @@ static const struct board_info __initcon
+@@ -4968,6 +5080,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 2799f2277db2f56cc9658ef27f72505cb17a5a55..d3166848d36280f7618c5596c7e596473e42b3bb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4586,6 +4586,116 @@ static struct board_info __initdata boar
+@@ -4587,6 +4587,116 @@ static struct board_info __initdata boar
        .has_ehci0 = 1,
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -5079,6 +5189,7 @@ static const struct board_info __initcon
+@@ -5080,6 +5190,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 286ae62f363f04a15cae00e29102d6f553e52c5e..0b1c36d7777a8fe5150ed80463ff80724552cf31 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4696,6 +4696,116 @@ static struct board_info __initdata boar
+@@ -4697,6 +4697,116 @@ static struct board_info __initdata boar
        },
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -5190,6 +5300,7 @@ static const struct board_info __initcon
+@@ -5191,6 +5301,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index 9b770cf1fe8a5c3639a243f70f2830993601497b..4e2ec75a8f8301f991dd9e7e3b3a0a5ab03a9306 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4595,6 +4595,96 @@ static struct sprom_fixup __initdata vr3
+@@ -4596,6 +4596,96 @@ static struct sprom_fixup __initdata vr3
        { .offset = 115, .value = 0xfad9 },
  };
  
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .expected_cpu_id                = 0x6368,
-@@ -5299,6 +5389,7 @@ static const struct board_info __initcon
+@@ -5300,6 +5390,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index e035f39d538899e64f44c0b2471e9628e68e7cc7..fc229e4df8c67bd04030f312bddcb70d18d17fe7 100644 (file)
@@ -57,7 +57,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -5372,6 +5422,7 @@ static const struct board_info __initcon
+@@ -5373,6 +5423,7 @@ static const struct board_info __initcon
        &board_nb4_fxc_r1,
        &board_nb4_fxc_r2,
        &board_ct6373_1,
index 3369b5256fafd9d60db55441a09b8164ed46c77b..60f3e451bbb815ee1ac97ef83ee7940a08e155f8 100644 (file)
@@ -96,7 +96,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .expected_cpu_id                        = 0x6328,
-@@ -5370,6 +5459,7 @@ static const struct board_info __initcon
+@@ -5371,6 +5460,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index 13fa11df08e96a85333dea303441f28d0b9280c0..a4df990e40a1ca0c6835cd73e02ab98f336aa7fd 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5453,6 +5588,7 @@ static const struct board_info __initcon
+@@ -5454,6 +5589,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,