odhcp6c: don't assign addresses or prefixes prematurely
authorSteven Barth <cyrus@openwrt.org>
Wed, 8 Oct 2014 15:16:19 +0000 (15:16 +0000)
committerSteven Barth <cyrus@openwrt.org>
Wed, 8 Oct 2014 15:16:19 +0000 (15:16 +0000)
SVN-Revision: 42850

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.script

index 52d41a8d3004ee573a084c67d2013fe7ecc03d85..6ebfe4ee17967514970c2447cc1c3114e7d79100 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2014-10-08
+PKG_VERSION:=2014-10-08.1
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=6373af63310f32e1408a81f4e4e069a5f0d3e59e
+PKG_SOURCE_VERSION:=569a7bbe8a181b0e48cb12c751988406de3d7f0b
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 
 include $(INCLUDE_DIR)/package.mk
index 37e67bfe522b1dbfdd5c891de69589a8712bdc3d..0fedaaa1cd886f11ecd0a03fc4666796a99cce98 100755 (executable)
@@ -158,6 +158,9 @@ case "$2" in
        informed|updated|rebound|ra-updated)
                setup_interface "$1"
        ;;
+       ra-updated)
+               [ -n "$ADDRESSES$RA_ADDRESSES$PREFIXES$USERPREFIX" ] && setup_interface "$1"
+       ;;
        started|stopped|unbound)
                teardown_interface "$1"
        ;;