package/compcache: move configuration in submenu
authorNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 09:54:27 +0000 (09:54 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 09:54:27 +0000 (09:54 +0000)
SVN-Revision: 20906

package/compcache/Config.in
package/compcache/Makefile

index 9904237edc6c52b8a697d7187111e6d99649d2a9..11a94d434205c19eda5088759801964bae9c308e 100644 (file)
@@ -1,15 +1,14 @@
-# compcache configuration
+menu "Configuration"
+       depends on PACKAGE_kmod-compcache
 
 config COMPCACHE_ENABLE
        bool "enabled on boot"
        default n
-       depends on PACKAGE_kmod-compcache
        help
          Enables compressed ram swap devices.
 
 config COMPCACHE_RAM_REPORTED
        string "swap space reported to kernel in kb"
-       depends on PACKAGE_kmod-compcache
        default "2048"
        help
          This is the amount of memory that will be reported 
@@ -21,10 +20,10 @@ config COMPCACHE_RAM_REPORTED
 
 config COMPCACHE_BACKUP_DEV
        string "Backup device for compcache"
-       depends on PACKAGE_kmod-compcache
        default ""
        help
          Compcache will use this as a backup device for swap.
          Example:
                 /dev/sda5
 
+endmenu
index 2fec2895277ed3ed47230cc0121d08e88a11032e..13a9056db41da59ff66e9958fce2f7e2bfd86b75 100644 (file)
@@ -26,6 +26,7 @@ define KernelPackage/compcache
   VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)+$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/ramzswap.$(LINUX_KMOD_SUFFIX) \
         $(PKG_BUILD_DIR)/sub-projects/compression/lzo-kmod/lzo1x.$(LINUX_KMOD_SUFFIX)
+  MENU:=1
 endef