ramips: use correct parameters in the Seama template
authorGabor Juhos <juhosg@openwrt.org>
Fri, 23 Aug 2013 17:07:26 +0000 (17:07 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 23 Aug 2013 17:07:26 +0000 (17:07 +0000)
Fixes DIR-645 image generation errors:

  bash: line 0: [: wrgn39_dlob.hans_dir645: integer expression expected
  ...
  bash: wrgn39_dlob.hans_dir645 - 64: syntax error: invalid arithmetic operator (error token is ".hans_dir645 - 64")  make[4]: *** [install] Error 1

Signed-off-by: Michael Lee <igvtee@gmail.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 37828

target/linux/ramips/image/Makefile

index 18f0fe5e0eca71186b9cbdab089279c8439ce8f2..ba7f6608a534eea5149e6185690d69c3afb64ec2 100644 (file)
@@ -156,9 +156,9 @@ BuildFirmware/Edimax/initramfs=$(call BuildFirmware/OF/initramfs,$(1),$(2),$(3))
 
 # build Seama header images
 define BuildFirmware/Seama/squashfs
-       $(call BuildFirmware/OF,$(1),$(2),$(3),$(4))
+       $(call BuildFirmware/OF,$(1),$(2),$(3),$(5))
        cat $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/root.$(1) > $(KDIR)/img_$(2).$(1).tmp
-       if [ `stat -c%s "$(KDIR)/img_$(2).$(1).tmp"` -gt $$$$(($(4) - 64)) ]; then \
+       if [ `stat -c%s "$(KDIR)/img_$(2).$(1).tmp"` -gt $$$$(($(5) - 64)) ]; then \
                echo "Warning: $(KDIR)/img_$(2).$(1).tmp is too big" >&2; \
        else \
                dd if=$(KDIR)/vmlinux-$(2).bin.lzma of=$(KDIR)/vmlinux-$(2).bin.lzma.padded bs=64k conv=sync; \