add wol (wake on lan)
authorFelix Fietkau <nbd@openwrt.org>
Sat, 26 Mar 2005 01:13:35 +0000 (01:13 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 26 Mar 2005 01:13:35 +0000 (01:13 +0000)
SVN-Revision: 458

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/wol/Config.in [new file with mode: 0644]
openwrt/package/wol/Makefile [new file with mode: 0644]
openwrt/package/wol/wol.control [new file with mode: 0644]

index 24d03a4001f9e47c33229e4d4e02390fc9497982..0c8a0351071a365a8890433329d79c5fd93dc752 100644 (file)
@@ -31,6 +31,7 @@ source "package/ez-ipupdate/Config.in"
 source "package/portmap/Config.in"
 source "package/nfs-server/Config.in"
 source "package/ser/Config.in"
+source "package/wol/Config.in"
 
 comment "Libraries"
 source "package/zlib/Config.in"
index 7ea5380f532ac6a9234f4d04dc97fe889ba00394..95e7d7067632a736327770eefc28b5fce19d00af 100644 (file)
@@ -34,6 +34,7 @@ package-$(BR2_PACKAGE_PPTPD) += pptpd
 package-$(BR2_PACKAGE_SER) += ser
 package-$(BR2_PACKAGE_STRACE) += strace
 package-$(BR2_PACKAGE_TCPDUMP) += tcpdump
+package-$(BR2_PACKAGE_WOL) += wol
 package-$(BR2_PACKAGE_ZLIB) += zlib
 
 all: compile install
diff --git a/openwrt/package/wol/Config.in b/openwrt/package/wol/Config.in
new file mode 100644 (file)
index 0000000..c9e0383
--- /dev/null
@@ -0,0 +1,5 @@
+config BR2_PACKAGE_WOL
+       tristate "Wake On LAN client"
+       default m
+       help
+         wol implements Wake On LAN functionality in a small program. It wakes up hardware that is Magic Packet compliant.
diff --git a/openwrt/package/wol/Makefile b/openwrt/package/wol/Makefile
new file mode 100644 (file)
index 0000000..fa8505c
--- /dev/null
@@ -0,0 +1,73 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wol
+PKG_VERSION:=0.7.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=c2fa9d7e771134ac8c89d56b8197d4ca
+
+PKG_SOURCE_URL:=@SF/ahh
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+
+$(DL_DIR)/$(PKG_SOURCE):
+       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+
+$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
+       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(PKG_BUILD_DIR)/.unpacked
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+               ac_cv_func_malloc_0_nonnull=yes \
+               ac_cv_func_realloc_0_nonnull=yes \
+               ac_cv_func_mmap_fixed_mapped=yes \
+               jm_cv_func_working_malloc=yes \
+               ac_cv_func_alloca_works=yes \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --libexecdir=/usr/lib \
+               --sysconfdir=/etc \
+               --datadir=/usr/share \
+               --localstatedir=/var \
+               --mandir=/usr/man \
+               --infodir=/usr/info \
+               $(DISABLE_NLS) \
+               $(DISABLE_LARGEFILE) \
+       );
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/src/$(PKG_NAME): $(PKG_BUILD_DIR)/.configured
+       $(MAKE) CC=$(TARGET_CC) -C $(PKG_BUILD_DIR)
+
+$(PKG_IPK): $(PKG_BUILD_DIR)/src/$(PKG_NAME)
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       mkdir -p $(PKG_IPK_DIR)/usr/sbin
+       cp $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(PKG_IPK_DIR)/usr/sbin/
+       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
+       mkdir -p $(PACKAGE_DIR)
+       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
+       $(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.unpacked
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+
+clean:
+       rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
diff --git a/openwrt/package/wol/wol.control b/openwrt/package/wol/wol.control
new file mode 100644 (file)
index 0000000..c1bdce5
--- /dev/null
@@ -0,0 +1,6 @@
+Package: wol
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: A Program to send magic Wake-on-LAN packets