disable ip6tables as well on 2.6.25 until we have working IMQ support
authorNicolas Thill <nico@openwrt.org>
Sun, 11 May 2008 22:41:49 +0000 (22:41 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 11 May 2008 22:41:49 +0000 (22:41 +0000)
SVN-Revision: 11117

package/kernel/modules/netfilter.mk

index 9262605abc84ccb19b79adaec4d28aa4d79e3c78..ec9f68c866481183f3352f1a4a0d6dc841ff499e 100644 (file)
@@ -272,10 +272,11 @@ endef
 $(eval $(call KernelPackage,ipt-extra))
 
 
 $(eval $(call KernelPackage,ipt-extra))
 
 
+# XXX: disabled on 2.6.25 due to broken IMQ
 define KernelPackage/ip6tables
   SUBMENU:=$(NF_MENU)
   TITLE:=IPv6 modules
 define KernelPackage/ip6tables
   SUBMENU:=$(NF_MENU)
   TITLE:=IPv6 modules
-  DEPENDS:=+kmod-ipv6
+  DEPENDS:=+kmod-ipv6 @!LINUX_2_6_25
   KCONFIG:=CONFIG_IP6_NF_IPTABLES
   FILES:=$(foreach mod,$(IPT_IPV6-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,40,$(notdir $(IPT_IPV6-m)))
   KCONFIG:=CONFIG_IP6_NF_IPTABLES
   FILES:=$(foreach mod,$(IPT_IPV6-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,40,$(notdir $(IPT_IPV6-m)))